1. #1

    Some addon is probably causing me to lag

    So, lately I've been experiencing a good amount of random lags (not freezes, but "people running in place"-like), and latency spikes (usually only world, home stays cool). This only happens to START when I'm in battle, so usually in raids/lfr but sometimes also during lvling. This has started with 5.3. I suspect one of my addons is causing it, because it never happens out of combat (and I have a lot of addons such as tidyplates, power auras etc that work practically only in combat). Those spikes are completely random, unpredictable and short enough for me to not be able to check which one it is by just relogging and turning them off one by one (because the spike will probably end already by itself). Any idea how to check it or maybe do you know which of the commonly used addons might cause that? Also, I'm not talking about FPS drops, my fps is fine.

  2. #2
    Immortal Treelife's Avatar
    Join Date
    Mar 2010
    Location
    England
    Posts
    7,025
    You can narrow the addon down much quicker by doing it in, say, halves.

    Disable half the addons, if it still happens it's in the half you left on. Then disable half of them and see if it happens or not. And so on. No need to do it one by one.

    Chances are it will be something like that looks at the combat log intensively, e.g. Recount or PAC (depending on how you use it). That is if it is an addon in the first place. I've never experienced that caused by an addon personally.

  3. #3
    The only potential way an addon could have an impact on latency is a considerable amount of communication.
    As far as I am aware that has not been an issue for quite some time.

    However there is an addon to monitor, and try and identify the source of that communication for known "chatty" addons.
    It it called Spamalyzer.

  4. #4
    I was having an FPS drop recently. De-bugged it by switching addons one at a time - turned out to be Power Auras.

  5. #5
    If understand your description correctly it sounds like it's highly unlikely to be an addon issue. Much more likely for it to be an issue with your internet connection, whether it be in your local network, on Blizzard's end, or somewhere in between.

    That's assuming you're talking about like 1-10 second latency spikes. Something more like 20-60s spikes during combat log intense parts of combat probably is addon related, but the first issue you described in your post would then have to be something else entirely.
    Last edited by aggixx; 2013-06-30 at 09:21 AM.

    Feral Druid Maintainer of SimC // Moderator at Fluid Druid forums
    Pawkets' Armory
    // Pawkets' Pro Raiders // <Forgotten Aspects>

  6. #6
    Quote Originally Posted by Sephrie View Post
    So, lately I've been experiencing a good amount of random lags (not freezes, but "people running in place"-like), and latency spikes (usually only world, home stays cool). This only happens to START when I'm in battle, so usually in raids/lfr but sometimes also during lvling. This has started with 5.3. I suspect one of my addons is causing it, because it never happens out of combat (and I have a lot of addons such as tidyplates, power auras etc that work practically only in combat). Those spikes are completely random, unpredictable and short enough for me to not be able to check which one it is by just relogging and turning them off one by one (because the spike will probably end already by itself). Any idea how to check it or maybe do you know which of the commonly used addons might cause that? Also, I'm not talking about FPS drops, my fps is fine.
    Something like this?

    http://www.youtube.com/watch?v=STCEQzV7prg

    @about 20 seconds it starts.

    I've been trying to find what is causing it for me but was so far unable to find anything.

  7. #7
    The way you describe your issue, OP, it sounds entirely like an internet issue, and not an addon issue.

    This blue post describing the differences between home and world latency should help:

    http://us.battle.net/wow/en/forum/topic/2065776684

  8. #8
    Are you using Oqueue? I was having the same problems until I removed it and re-installed it.

  9. #9
    Have you solved this yet? I'm being plagued by this currently

  10. #10
    Stood in the Fire
    Join Date
    May 2011
    Location
    New York City
    Posts
    350
    **If it's oqueue - something happens when 128 premades show up (could be 124) but it was documented and confirmed by tiny.
    Can't find source right this second but I believe it was even mentioned on another mmo-champ post.

    Armory : Fear@Cho'Gall UI Screen : Elv UI Wow Progress : Vindictive
    Cpu : Intel I7-2600k Mem : 16gb Corsair Vengeance Psu : Corsair HX1050 Gfx : EVGA GTX 770

  11. #11
    You're probably referring to this post.
    UI & AddOns expert | Interface & Macros moderator - My work

  12. #12
    addons that can give lag are mostly dmg addons
    scrolling combat text
    mikscombattext

    use the filters IF its that i encountered it before when raiding
    Same Shit Different Day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •