1. #1

    Random macro fail

    #showtooltip
    /cast [target=mouseover, exists, noharm][target=target, exists, noharm][target=player] Earth Shield


    This should work.. but doesnt

    ive tried moving keybinds, ive re written it and it still doesnt work.

    I copied the same script from my gwh/hw mouseovers and they work fine.. on any bind. but this wont work at all other than my direct targeted player.

    Any suggestions? its starting to do my head in now

  2. #2
    I remember reports of bugs with mouseover earth shield that had to do with the unitframes in use and/or the keybind. Sorry i cant be more precise, i just remember having heard of that problem specifically with earth shield recently. I think it was the blizzard standard raid ui that was the problem.
    You could always shorten it to "@mouseover" etc, but that's just about tidyness and not functionality. I'm pretty sure the error is not on your end.

  3. #3
    Quote Originally Posted by Erzengel View Post
    I remember reports of bugs with mouseover earth shield that had to do with the unitframes in use and/or the keybind. Sorry i cant be more precise, i just remember having heard of that problem specifically with earth shield recently. I think it was the blizzard standard raid ui that was the problem.
    You could always shorten it to "@mouseover" etc, but that's just about tidyness and not functionality. I'm pretty sure the error is not on your end.
    thanks. Have tried clique but stil lto no avail. even just hovering over people in a city isnt working so im begning to think the ability just cant be macrd

  4. #4
    What happens if all you put in is

    #showtooltipp Earth Shield
    /cast [@mouseover][] Earth Shield

    or

    #showtooltipp Earth Shield
    /cast [@mouseover, help][] Earth Shield

    Should ES mouseover if the target is a viable ES target, and take your normal target if there's no mouseover that can be eartshielded.

    I remember having mouseover earth shield macros and using the default raid ui in cataclysm, so at one point it worked. Keybind was C. Macro was something along the lines of this:
    "/cast [mod:alt, @player][@mouseover, exists][] Earth Shield"


    Anyway, i cant check ingame right now, so good luck with your macro. Hope you find a solution

  5. #5
    Quote Originally Posted by Erzengel View Post
    What happens if all you put in is

    #showtooltipp Earth Shield
    /cast [@mouseover][] Earth Shield

    or

    #showtooltipp Earth Shield
    /cast [@mouseover, help][] Earth Shield

    Should ES mouseover if the target is a viable ES target, and take your normal target if there's no mouseover that can be eartshielded.

    I remember having mouseover earth shield macros and using the default raid ui in cataclysm, so at one point it worked. Keybind was C. Macro was something along the lines of this:
    "/cast [mod:alt, @player][@mouseover, exists][] Earth Shield"


    Anyway, i cant check ingame right now, so good luck with your macro. Hope you find a solution
    tried both to no avail. i always used to use the same mouseover in cata aswell but for some reason now it doesnt work. it seems from playing it just does not want to work as mouseover on any command script. and i really dont get why. Dont particularly want to have to run an addon for one ability

  6. #6

  7. #7
    Warchief Meteoria's Avatar
    Join Date
    Jul 2012
    Location
    Space Walrus
    Posts
    2,027
    #showtooltip
    /cast [@mouseover] Earth Shield

    That should work.
    Quote Originally Posted by simsumre View Post
    I'm a Conservative American. I'm not able to peacefully protest my Government without being pepper sprayed. Liberal Democrats control my country and I'm being politically persecuted. Where's my asylum?

  8. #8
    Field Marshal
    Join Date
    Jun 2011
    Location
    Mal'Ganis - US
    Posts
    69
    Quote Originally Posted by Tsubodia View Post
    #showtooltip
    /cast [target=mouseover, exists, noharm][target=target, exists, noharm][target=player] Earth Shield


    This should work.. but doesnt

    ive tried moving keybinds, ive re written it and it still doesnt work.

    I copied the same script from my gwh/hw mouseovers and they work fine.. on any bind. but this wont work at all other than my direct targeted player.

    Any suggestions? its starting to do my head in now
    I just copied your above macro in-game, replaced it with my current ES macro, then tried it out. It must be something wrong on your end. That macro works perfectly fine for me.

  9. #9
    Quote Originally Posted by Saevio View Post
    I just copied your above macro in-game, replaced it with my current ES macro, then tried it out. It must be something wrong on your end. That macro works perfectly fine for me.
    thats the odd thing. all other macros i have on the same format work fine. just not this one. Have tried clique, blizz basic ui frames, clique. nothing seems to want to work with it

  10. #10
    is it bound to a mouse or a keyboard button? mouse is reported to bug out

  11. #11
    The Patient
    Join Date
    Nov 2008
    Location
    Arizona
    Posts
    336
    What unit frames are you using?

  12. #12
    Field Marshal
    Join Date
    Jun 2011
    Location
    Mal'Ganis - US
    Posts
    69
    Quote Originally Posted by Tsubodia View Post
    thats the odd thing. all other macros i have on the same format work fine. just not this one. Have tried clique, blizz basic ui frames, clique. nothing seems to want to work with it
    I also have ES set up in clique and it works just fine. In the clique bindings settings when you open up the spellbook, my ES is bound to Mouse Wheel Down, and under the click-set option, it is set to default and hover-cast. I can put my mouse over anyone as long as they are appropriate to receive ES, mouse wheel down over them, and it will cast ES on them.

  13. #13
    Quote Originally Posted by Erzengel View Post
    is it bound to a mouse or a keyboard button? mouse is reported to bug out
    has been on both mouse and keyboard bind. neither worked. i can also put ghw on the bind ES was on and ghw works fine there..

    Quote Originally Posted by Caladia View Post
    What unit frames are you using?
    atm im back on elvui frames. When i first had the issue i was on blizz own frames, then tried grid aswell to no avail

    Quote Originally Posted by Saevio View Post
    I also have ES set up in clique and it works just fine. In the clique bindings settings when you open up the spellbook, my ES is bound to Mouse Wheel Down, and under the click-set option, it is set to default and hover-cast. I can put my mouse over anyone as long as they are appropriate to receive ES, mouse wheel down over them, and it will cast ES on them.
    il have another play with clique tomorow see if i can get it up and working

    - - - Updated - - -

    Quote Originally Posted by Saevio View Post
    I also have ES set up in clique and it works just fine. In the clique bindings settings when you open up the spellbook, my ES is bound to Mouse Wheel Down, and under the click-set option, it is set to default and hover-cast. I can put my mouse over anyone as long as they are appropriate to receive ES, mouse wheel down over them, and it will cast ES on them.
    Thank you! This worked perfectly.

  14. #14
    #showtooltip
    /cast [target=mouseover,help] Earth Shield; [help] Earth Shield; Earth Shield

    thats the one that i use for all my healing spells

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •