1. #1
    Warchief Zeror's Avatar
    Join Date
    Aug 2009
    Location
    The Netherlands
    Posts
    2,180

    Lots of YouTube makes the site slow.

    Everytime, you guys at MMO-Champion, a newspost with a lot of embedded YouTube is added I encounter the problem that the frontpage of this website is very very slow. It loads slow and it scrolls slow. Not a very nice way to view your website. On a mobile phone it's even worse as the mobile internet connection is a bit slower. It takes a long time until the website is fully loaded. My browser (Firefox 23.0.1) needs about 9 - 10 seconds to load the frontpage. My mobile browser (Dolphin) needs even more time. After 18 - 19 seconds my phone has loaded the frontpage on my home Wifi connection!!! That is way too long.

    Can you please limit the usage of embedded youtube video's in a newspost? That would make it much much better to view this website.

  2. #2
    I'll have to agree. Opening MMO-Champ brings Chrome to a standstill for at least 5-10 seconds on my PC. I even had my phone's browser crash once from all the videos.

  3. #3
    You have to wait 10 seconds!? OH NOES.

    EDIT: If it's crashing your browser it's probably time to upgrade your calculator.
    Quote Originally Posted by Dj
    your a Gnome, how the heck does it feel to suck that badly?
    Quote Originally Posted by Xtacle
    Gnomes are awesome, and piss people off, how does it feel to die to a tiny pink puffball?

  4. #4
    Warchief Zeror's Avatar
    Join Date
    Aug 2009
    Location
    The Netherlands
    Posts
    2,180
    Quote Originally Posted by russ555 View Post
    You have to wait 10 seconds!? OH NOES.

    EDIT: If it's crashing your browser it's probably time to upgrade your calculator.
    The problem is not my computer, which is a decent PC (3,5 years old currently was bought as high-end game pc).

    Oh, and those 10 seconds are not the problem. I can wait a couple of seconds, no problem with that. But... 10 seconds loading these days are really not done and it basicly means your site is weak and inefficient and that makes this website real slow. Especially when there are like 8 embedded youtube video's on one page. And the advertisements doesn't really help either on the websites loading speed. Most of the time ads are even worse for your website then anything else. I tried an adblocker to improve loading speed, but if the MMO-C staff keeps posting a lot of youtubes then it doesn't really help in this case.
    Last edited by Zeror; 2013-09-11 at 10:05 AM.

  5. #5
    Immortal Baar's Avatar
    Join Date
    Nov 2010
    Location
    Northern Michigan
    Posts
    7,229
    Quote Originally Posted by Zeror View Post
    The problem is not my computer, which is a decent PC (3,5 years old currently was bought as high-end game pc).

    Oh, and those 10 seconds are not the problem. I can wait a couple of seconds, no problem with that. But... 10 seconds loading these days are really not done and it basicly means your site is weak and inefficient and that makes this website real slow. Especially when there are like 8 embedded youtube video's on one page. And the advertisements doesn't really help either on the websites loading speed. Most of the time ads are even worse for your website then anything else. I tried an adblocker to improve loading speed, but if the MMO-C staff keeps posting a lot of youtubes then it doesn't really help in this case.

    I don't think it's MMO champ. I'm not getting long load times here and I'm on crappy dsl. (work pc)

  6. #6
    Super Moderator Darsithis's Avatar
    Join Date
    Jan 2011
    Location
    Chicago
    Posts
    29,267
    Quote Originally Posted by Baar View Post
    I don't think it's MMO champ. I'm not getting long load times here and I'm on crappy dsl. (work pc)
    I don't think it is MMOC either. On my work laptop I get a lot of system lag and hang time when loading video megathreads (but not the front page), and none at my home desktop. The major difference is my home PC is SSD and a gaming system while my work laptop is frequently overloaded with instances of Visual Studio and Sql Server.

    I don't personally have any suggestions, though. I'm not sure why it would take so long for embedded videos to load for you on that system.
    SUCH INFRACTIONS
    MANY POST
    SO POWERFUL
    WOW

    (Armory) | (Twitter)
    Global Moderator of MMO-Champion.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •