1. #1

    Upgraded from weak auras 1 to weak auras 2 and now ALL My 100s of weak auras are GONE

    So on curse weak auras, it says just delete weak auras 1, uncheck delete saved variable, and then install weak auras 2 and everything will be working fine.
    I do that and now i have NO weak auras at all. /wa is empty, saved variables folder has weakaura.lua , freakin empty. No weak aura files under specific character folders in WTF, or in their saved variables. Are all my weak auras lost now or is there a way to recover them??

  2. #2
    Mechagnome shanthi's Avatar
    Join Date
    Oct 2011
    Location
    California
    Posts
    713
    I upgraded to Weak Auras 2 without any loss of auras. Do you have a backup of your weakauras.lua saved variables file? It's only saved at the account level, not the character level. If you have a copy of it, you could probably copy the code for the auras from that and paste it into the appropriate place in the "empty" file you now have. If you have no copy of it, they're gone for good because that's the only place the auras are stored.
    That is not dead which can eternal lie.
    And with strange aeons even death may die.

  3. #3
    Ok let me clarify since I was/am in a raging mood, I updated to WA2 on thursday/friday. They were working fine on saturday on my hunter, then I log on wow on Sunday, on warlock, no weak auras, check hunter, no weak auras. check saved variables weakaura.lua, freakin nothing in it.
    so is it gone for good? would system restore fix it or ?

  4. #4
    Quote Originally Posted by Crowz85 View Post
    Ok let me clarify since I was/am in a raging mood, I updated to WA2 on thursday/friday. They were working fine on saturday on my hunter, then I log on wow on Sunday, on warlock, no weak auras, check hunter, no weak auras. check saved variables weakaura.lua, freakin nothing in it.
    so is it gone for good? would system restore fix it or ?
    After you updated to WA2 did anything happen? Mainly, an unusual boot down of you computer? Crash, or even you just hitting the off switch because #yolo?
    ~There's only two good parts in a dubstep song. The first is when it's not wubbing, the second is when it ends.~

  5. #5
    Nope, nothing like that, rest of my addons havnt reset, just Weak auras..

  6. #6
    Roughly the same thing happened to me, but I had previously read about people having issues so I did a backup of all the weakauras savedvariables before I even did the update to WA2. First raid night after update, logged in with WA2, everything was there working fine. Second raid night, everything was gone. Uninstalled WA2, cleared savedvariables, installed WA1, restored backup'd savedvariables, back to normal. I've thought about writing all my auras down and remaking them from scratch in WA2 but it would probably take a few hours........ and what guarantee do I have after all that that they won't get randomly cleared again. Since WA1 still works I don't see much reason to update (even though I got a bunch of guildies to update to WA2 with me, and of course they had no issues, but I did, so now I can no longer share auras with most of the raid).

    You might be able to do the windows "Restore previous versions..." thing, but I've never really used it to know how reliable it is.
    Main - Spirál - Hunter - 11/14 10H SoO - 13/13 10H ToT (Retired)
    Alt - Rerolling - BrM Monk

    Ex-GM of <Convicted>/<Ginyu Force> on US-Stormreaver
    http://www.sr-ginyuforce.com/home - Kill Videos
    Hunter Simcraft Profile Generator web tool

  7. #7
    Just a tip, maby to late but every weak before updates I backup my interface+wtf folder. That way you can always roll back and retrieve stuff.

  8. #8
    Mechagnome shanthi's Avatar
    Join Date
    Oct 2011
    Location
    California
    Posts
    713
    Quote Originally Posted by Snookki View Post
    Just a tip, maby to late but every weak before updates I backup my interface+wtf folder. That way you can always roll back and retrieve stuff.
    Yup. I also keep a relatively up-to-date copy of those two directories in DropBox so that if I have to play WoW on another computer (like when I had to raid on my laptop because my PC needed a repair), I can always access my latest UI.
    That is not dead which can eternal lie.
    And with strange aeons even death may die.

  9. #9
    Field Marshal
    Join Date
    Jun 2011
    Location
    Mal'Ganis - US
    Posts
    69
    Every time I have heard about someone having trouble with updating to WA2 from WA1, there is usually one common thread. They have all used the curse client to update. I personally updated to the new weak auras manually. Deleted the old WA from addons folder only. Downloaded new WA from curse website, unzip it, and manually add it to addons folder. I haven't had a single issue since updating which was nearly 4 weeks ago.

  10. #10
    There may still be hope if you have windows 7 and it has shadow copy turned on. Navigate to your addons folder in windows explorer, right click on the folder, select properties, and click on the previous versions tab. At this point you hope and pray you have it turned on. If you do, previous versions of the folder will be listed, you can then open those, and recopy the old addon back - this has saved me a few times from a similar situation.

    More information on Windows Shadow copies is found here:

    http://windows.microsoft.com/en-ca/w...sked-questions
    Last edited by Treviathon; 2013-10-08 at 08:14 PM.

  11. #11
    Quote Originally Posted by Treviathon View Post
    There may still be hope if you have windows 7 and it has shadow copy turned on. Navigate to your addons folder in windows explorer, right click on the folder, select properties, and click on the previous versions tab. At this point you hope and pray you have it turned on. If you do, previous versions of the folder will be listed, you can then open those, and recopy the old addon back - this has saved me a few times from a similar situation.

    More information on Windows Shadow copies is found here:

    http://windows.microsoft.com/en-ca/w...sked-questions
    Actually restoring in the addons folder will not help, when it is the saved variables you need to be looking at.
    Mine having manually installed it outside of the Program Files folder is located inside the WoW installation folder in WTF, but that location could well be, and almost certainly different if you performed an installation in the default location.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •