1. #1
    High Overlord Zyl's Avatar
    Join Date
    Sep 2008
    Location
    Woodland, CA
    Posts
    105

    Razer Synapse 2.0 and Kraken headset

    Hi, my BF recently got me a Razer Kraken 7.1 headset for my bday. I went to pick it up today at the store and when I plug the USB in, Windows detects it as a viable "voice" device, but Synpase does not recognize it at all so I cannot set up the 7.1 or any audio controls for it. Does anybody know what I am overlooking? My BlackWidow Ultimate and Ouroboros are both being detected and function just fine. I just did a long overdue update for Synapse and it didn't recognize it after doing that either. My current software version for Synpase is 1.16 (It is the Synpase 2.0), and I am logged into my cloud for my settings. Thank you to anybody who has any sort of advice on how to get it to function.

  2. #2
    Immortal Soisoisoi's Avatar
    Join Date
    Mar 2010
    Location
    England
    Posts
    7,405
    Have you tried restarting the PC with them plugged in?

  3. #3
    High Overlord Zyl's Avatar
    Join Date
    Sep 2008
    Location
    Woodland, CA
    Posts
    105
    Quote Originally Posted by Treelife View Post
    Have you tried restarting the PC with them plugged in?
    Yes, I have also unplugged them and plugged them back in to see if it will recognize them in the software, and it does not. When I first plugged my BlackWidow in (after I had my Ouroboros) it automatically installed drivers and gave me an option on the bottom panel for the keyboard. My Windows does list the headset under Sounds and Audio Devices, too.

  4. #4
    Hi,

    Try removing Razer Synapse first. Once you've done that, go to your folders and make sure that you delete anything Razer-related (don't worry, your settings will be saved on the cloud, so things will get back again when you re-install it). Now, go to their website, and download it again. I'd recommend having all Razer peripherals plugged in prior running Synapse, just so that it detects everything at the same time. It'll probably ask you to restart your PC, do so and then open Synapse again and see if the headset has been detected or not.

    Hope that helps, because I used that headset for a short period of time, and I had the exact same issue as well. Once I did what I mentioned above, Synapse detected the headset without any problems. Best of luck.
    "Those mortal shells that we call bodies, are not ours to keep. The body is a gift of earth that must, one day, be returned from whence it came"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •