1. #1

    Is there an actual fix to the "Mouse resets to center when clicking" bug?

    For those lucky ones who haven't encountered this bug yet, here's how it works: when clicking any mouse button in WoW, the mouse cursor often jumps to the center of your screen. If this happens while moving / camera panning, it will cause you to jerk around and change direction randomly (i.e. instant involuntary 180° turns etc.), which is of course a huge disadvantage as it can make you run off cliffs and hinder you when trying to select a target.

    This bug has been around for as long as I can remember. However, the frequency is what changed. It never happened often enough to really be more than a slight annoyance, but recently it's been happening about once every 10 clicks, which makes it almost impossible to play properly (especially PvP).

    At first I thought it was caused by Win 8.1, which was partly true. Win 8.1 seems to have a problem that causes this bug in a lot of games, and it happened with almost every click in WoW. I've installed the fix provided by Microsoft, which brought it back down to about 10% of clicks. However, a friend of mine using Windows 7 has the same problem.

    It also happens with no addons on a fresh installation, as well as on a completely different machine. I've also tried various other supposed bugfixes I've found on the official forums (disabling TabletInputService, updating drivers, using different cursor settings (hardware cursor, input lag, ...) and what have you) but so far nothing has helped.

    And of course this happens exclusively in WoW.

    Any ideas?

  2. #2
    what kind of mouse do you have?

    i had this issue with both my old razer naga and my g600. i fixed it by disabling the step up/down DPI system in the software and enabled acceleration

    hope it helps!


    AddOn Author of: SpellNotReadyYet, Rune of Powa

  3. #3
    Quote Originally Posted by SpaceDuck View Post
    what kind of mouse do you have?

    i had this issue with both my old razer naga and my g600. i fixed it by disabling the step up/down DPI system in the software and enabled acceleration

    hope it helps!
    I've tested it with a Razer Naga, a Logitech G5 and a Logitech MX518. No noticeable difference. I've tried enabling acceleration for the Naga, but that doesn't seem to change anything, either.

  4. #4
    are you 100% sure you disabled the DPI step up stuff? making sure the level is set to 1 and theres only 1 set DPI value?

    tried increasing the polling rate? if so, tried decreasing it?

    this is my settings: http://imgur.com/ewl8m8N

    is it the direct center of the screen it defaults back too? not just the mouse being thrown in a random direction? are you using a mouse matt? if the surface is too reflective it can interfer with the laser and throw it in random directions


    AddOn Author of: SpellNotReadyYet, Rune of Powa

  5. #5
    The menu doesn't allow for 1 step, the minimum is 2:



    I've also tried different settings for acceleration and polling rate:



    The mouse cursor resets to the center of the screen, it's not random. I've tested it on a black cloth mat, a black plastic pad, jeans, the back of my hand, a white sheet of paper, ... all the same I'm afraid.

  6. #6
    hm interesting, not used razer synapse in a while. is there no option to disable the stages altogether? tried changing both stages to the same value?


    AddOn Author of: SpellNotReadyYet, Rune of Powa

  7. #7
    Yup, but I don't think it's the Naga. Happens with all other mice I have as well.

    Some additional info I've found:

    The bug doesn't happen on my laptop at all. It does happen on my old desktop, though. It also occurs much more frequently in Windowed Fullscreen than it does in Fullscreen mode.

    Edit: I've found (most of) the culprit. I had FRAPS running. Closing it makes the bug (almost) disappear. Now the reset only happens about once every 5 minutes, which seems to be the "normal" frequency I've had before (and what a friend of mine is experiencing as well).
    Last edited by Feranor; 2014-01-03 at 03:42 PM.

  8. #8
    I've had this for years. It only happens when certain programs are running. Like you say, fraps is one of them. I also know newer versions of Mumble causes it, so I use some old version called 1.2.4-beta1-12 which works perfectly fine.

    Now the reset only happens about once every 5 minutes,
    Spam left click while dragging your mouse. You'll reproduce it within 5 seconds if any "problem-causing" program is running.
    Last edited by Calz; 2014-01-26 at 11:01 PM.

  9. #9
    http://us.battle.net/wow/en/forum/to...58?page=14#280

    Originally Posted by Velnrak
    Microsoft has just issued an update:

    Mouse pointer stutters or freezes when you play certain games in Windows 8.1

    http://support.microsoft.com/kb/2908279

    Please let us know if this helps with WoW, and the issues in this thread.
    Once you do this you have to extend WoW to the update

    Edit: If it says "The update is not applicable to your computer" that means it's already installed (may have been updated as it was sent out as a patch) meaning all you have to do is extend it to wow.
    Last edited by Erquonter; 2014-01-27 at 12:52 AM.

  10. #10
    Keyboard Turner Trixeh's Avatar
    Join Date
    Nov 2013
    Location
    United Kingdom
    Posts
    2
    There is a temp fix if you press both mouse buttons at the same time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •