1. #1

    Is Wowhead broken for you?

    The website itself is working, but everything is blank. What's going on?

  2. #2
    Nope, works for me just fine.

  3. #3
    Totally fine for me.

  4. #4

  5. #5
    The Insane peggleftw's Avatar
    Join Date
    Sep 2009
    Location
    Surrey, England
    Posts
    16,248
    Happens a lot on wow head for me, I have to keep refreshing until it works.
    Too cool for a signature

  6. #6
    Quote Originally Posted by peggleftw View Post
    Happens a lot on wow head for me, I have to keep refreshing until it works.
    Total derp. I refreshed and it's fine. I feel like an idiot

    That was weird though.

  7. #7
    The Insane peggleftw's Avatar
    Join Date
    Sep 2009
    Location
    Surrey, England
    Posts
    16,248
    Quote Originally Posted by Reyina View Post
    Total derp. I refreshed and it's fine. I feel like an idiot

    That was weird though.

    It's been happening for a while on wowhead now, seems to just sometimes not load anything on the page, and then random
    y start working again.
    Too cool for a signature

  8. #8
    Also try another browser, But I am a fan of firefox and this is a Wowhead issue.

  9. #9
    Dreadlord Amerin's Avatar
    Join Date
    Aug 2013
    Location
    California
    Posts
    811
    Quote Originally Posted by lockdown1 View Post
    Also try another browser, But I am a fan of firefox and this is a Wowhead issue.
    Google Chrome, never firefox. Anyways, never had issues with wowhead, weird.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •