1. #1

    Installing Hearhstone killed my WoW fps.

    Just a heads up....maybe this won't happen to you.... I installed the Hearthstone beta,and it installed a new launcher. My fps in WoW went down to 14 fps from the high 40's. So I uninstalled Hearthstone, and my WoW went back to normal ..... Then I tried again, and the same thing happened. Just wanted to let you know my experience...ymmv.

  2. #2
    Super Moderator Darsithis's Avatar
    Join Date
    Jan 2011
    Location
    Chicago
    Posts
    34,012
    It's very likely something other than Hearthstone. I have it installed, my partner has it installed, most of the mods have it installed, and not one of them has ever said that it killed their FPS.



  3. #3
    if this is the first time your using the new launcher for WoW, check it is running the desired version (32 bit or 64 bit). That is the only thing that I can think of that would affect your games performance.

  4. #4
    You don't have to launch WoW from the hearthstone launcher.

  5. #5
    Quote Originally Posted by Darsithis View Post
    It's very likely something other than Hearthstone. I have it installed, my partner has it installed, most of the mods have it installed, and not one of them has ever said that it killed their FPS.
    Why would it be anything else? The results were immediate. I never even attempted to play HS. And it happened both times I installed it.

  6. #6
    Dreadlord Amerin's Avatar
    Join Date
    Aug 2013
    Location
    California
    Posts
    811
    Hasn't killed my FPS, has to be something else. Try looking in your processes while WoW is running and see what's going on, could be some sort of background process taking up alot of CPU usage.

  7. #7
    Bring up task manager and take a look at what's eating your CPU when you've got WoW running.
    EU first PG wave 30, come at me bros.

  8. #8
    Did you fully install it or are you downloading it in the backround while playing WoW? Could you actually play Hearthstone before you starting playing WoW?
    Is this where the header goes?

  9. #9
    Quote Originally Posted by GarlicGuy View Post
    Just a heads up....maybe this won't happen to you.... I installed the Hearthstone beta,and it installed a new launcher. My fps in WoW went down to 14 fps from the high 40's. So I uninstalled Hearthstone, and my WoW went back to normal ..... Then I tried again, and the same thing happened. Just wanted to let you know my experience...ymmv.
    Installing Hearthstone caused serious issues on my computer. It seemed like almost everything was running slower when the launcher was open, not just WoW. The launcher may be launching the 32-bit version of the game on your 64-bit system or it could be another issue entirely, but I also narrowed my problems down to the launcher. Just change your WoW shortcut's properties to "C:\Program Files (x86)\World of Warcraft\Wow-64.exe" for 64-bit or \wow.exe (I think?) for 32-bit. All of those issues disappeared when I started bypassing the new launcher that way and I still have Hearthstone installed.

  10. #10
    "i dont see a problem you must be wrong" if everyone operated under the same conditions this might be true, they don't so it isn't.
    "Have you had the dream again? A black goat with seven eyes that watches from the outside."

  11. #11
    Pit Lord velde046's Avatar
    Join Date
    Jun 2009
    Location
    Netherlands
    Posts
    2,456
    Quote Originally Posted by GarlicGuy View Post
    Why would it be anything else? The results were immediate. I never even attempted to play HS. And it happened both times I installed it.
    The reason Darsithis mentioned it is unlikely is the fact that there are already thousands of beta players and apprently not many have that issue otherwise it would have been picked up earlier.... I am leaning towards two possibilities.

    First is that is something indeed with launcher nad 32- or 64-bits settings. Especially since you said you did not even play HS and that the beta installed a new launcher? Had no idea about that last part though.... did not see that on my own PC.

    Second.... nah let's just assume your statement is fair and true until proven otherwise.

  12. #12
    Pandaren Monk matheney2k's Avatar
    Join Date
    May 2010
    Location
    Las Vegas, NV
    Posts
    1,839
    Quote Originally Posted by akamurdoch View Post
    "i dont see a problem you must be wrong" if everyone operated under the same conditions this might be true, they don't so it isn't.
    You are so helpful and witty aren't you?

    And like Velde said, if hearthstone itself causes fps issues for WoW that would be something that would have been noticed long ago by the previous thousands of people that downloaded it in the past several months. It is more than likely something on the OP's end. A setting somewhere or what have you.

  13. #13
    Never heard of anyone else saying Hearthstone impacted WoW's FPS. So I'm guessing that it's probably something else. See what is using up your computer resources, because there's no way it has to do with Hearthstone.

  14. #14
    Dreadlord Icaras's Avatar
    Join Date
    Jul 2011
    Location
    Australia
    Posts
    874
    I've had Hearthstone installed for ages, and it's not affected my WoW whatsoever.

    Are you maybe trying to run both at once?
    You must show no mercy, Nor have any belief whatsoever in how others judge you: For your greatness will silence them all!
    -Warrior Wisdom

  15. #15
    It only took a one second Google search to find more people having this issue. They mentioned that it specifically seemed to have an issue with Alt+Tabbing, which is part of the issue that I was having, as well. The launcher didn't seem to be consuming any more resources than you would expect, but bypassing it solved the issue immediately. It was a huge difference.

  16. #16
    Congrats on finding a bug in an open beta.

    I don't have Hearthstone installed but I'm sure there's a bug report or customer service ticket thing inside it as well as WoW's ticket fuction. Be sure to say that it's happening because of the launcher.

    In the meantime try either launching WoW outside of the launcher or making sure it's running the X86 version. :-)

  17. #17
    Quote Originally Posted by Icaras View Post
    I've had Hearthstone installed for ages, and it's not affected my WoW whatsoever.

    Are you maybe trying to run both at once?

    Nope..... like I said, I never even tried to play HS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •