1. #1
    Stood in the Fire Tyranader's Avatar
    Join Date
    Oct 2012
    Location
    England
    Posts
    351

    Lost all my WeakAuras

    So I just lost all of my WeakAuras... Anyone know what causes this? I just logged in and they where all gone.

    EDIT: Restored from a backup. Got them all back.
    Last edited by Tyranader; 2014-03-08 at 08:12 PM.
    Tyranade - Holy - 655
    Highmaul
    7/7 - Normal | 6/7 - Heroic | 0/7 - Mythic
    Blackrock Foundry
    0/10 - Normal | 0/10 - Heroic | 0/10 - Mythic

  2. #2
    This happens to me sometimes, and it's not only weak auras but other addon settings. I have a feeling it may be related to the battle.net client and logging in/out through that then normally.

    Anyone else experiencing this?

  3. #3
    I can't say I have experienced it myself, but threads do pop up on occasion about addon settings being lost, particularly with people mentioning WeakAuras.
    I don't know if that is an issue with the addon or simply one people bring up due to not being able to recreate their configuration, which tends to be more complex than most other addons.
    Quote Originally Posted by DeadmanWalking View Post
    I don't understand why we don't have flying so they tell us we will have convenient flight points. Immersion and danger? Here take some coins and fly me there while I read facebook or go take a poop.
    Quote Originally Posted by Reinaerd View Post
    T'is good to see there are still people valiantly putting the "Ass" in assumption.

  4. #4
    Occasionally Weakauras will fail to correctly save an imported string to savedvariables. In my experience this will happen if you import a string and then immediately hit a loading zone. When you log back in, none of your auras will work, very few will display in the window, but they will ALL appear in the savedvariable.

    What you need to do in this case is locate the last imported aura in that file (not the last one listed, the last one you imported, by name) and manually remove it, taking care to remove only the correct number of brackets. Doing this in notepad is not recommended.

    While you're doing this, take a moment to wonder aloud why WeakAuras saves your auras in a completely random order having nothing to do with either alphabetical order nor creation date, each one with its elements similarly randomized.

  5. #5
    Stood in the Fire Tyranader's Avatar
    Join Date
    Oct 2012
    Location
    England
    Posts
    351
    Quote Originally Posted by Kingoomieiii View Post
    Occasionally Weakauras will fail to correctly save an imported string to savedvariables. In my experience this will happen if you import a string and then immediately hit a loading zone. When you log back in, none of your auras will work, very few will display in the window, but they will ALL appear in the savedvariable.

    What you need to do in this case is locate the last imported aura in that file (not the last one listed, the last one you imported, by name) and manually remove it, taking care to remove only the correct number of brackets. Doing this in notepad is not recommended.

    While you're doing this, take a moment to wonder aloud why WeakAuras saves your auras in a completely random order having nothing to do with either alphabetical order nor creation date, each one with its elements similarly randomized.
    Since I have soo many for every healing class and tank classes and raid debuffs from MoP etc I have ALOT of weak auras. Now every time I add 1 or 2 new auras I just back up my WTF folder.
    Tyranade - Holy - 655
    Highmaul
    7/7 - Normal | 6/7 - Heroic | 0/7 - Mythic
    Blackrock Foundry
    0/10 - Normal | 0/10 - Heroic | 0/10 - Mythic

  6. #6
    Quote Originally Posted by Frostbyte-2361 View Post
    This happens to me sometimes, and it's not only weak auras but other addon settings. I have a feeling it may be related to the battle.net client and logging in/out through that then normally.

    Anyone else experiencing this?
    I do, sometimes in combinations with other AddOns. WeakAuras seems to be the one causing it though for me. Stopped using WeakAuras for a while now because I dislike unreliability

  7. #7
    Field Marshal
    Join Date
    Sep 2012
    Location
    Boston, MA
    Posts
    81
    I've never had it happen to me, but it's happened to people in my guild. The best advice I can give is to either setup your machine to backup your interface/WTF folders every so often, or to just do it manually.

    I usually back my Interface/WTF folders up every couple of weeks just to be safe. I'll also back them up before/after doing any type of extensive aura modifications. It can be a pain in the ass, but nowhere near the pain that would be caused by having to recreate all of my auras.
    Jellogtwo - Druid - Royal Militia [A10] - Main - 14/14H
    Jellog - Monk - Royal Militia [A10] - Alt - 14/14H

    <Royal Militia> - 14/14H x2, US 27th (22nd for 10s only), is now recruiting all classes for WoD!

  8. #8
    I also back up my UI whenever someone else loses theirs.

    If you don't have a backup (or the backup isn't recent enough), you may also be able to restore the files to an earlier state using Windows (typically keeps a backup no more than 7 days old). Just right click the directory or file and look for "Restore Previous Version" or something like that.
    Minimerlinx - Kel'Thuzad (US)

    <Royal Militia> - 14/14H, US22 10m, is now recruiting all classes for WoD! Apply here!


  9. #9
    You can also stick your WTF folder in Dropbox or Google Drive, and make a virtual link back to the WoW directory. Dropbox keeps backups of files going back a few dozen file updates, even through deletions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •