1. #1

    shadowfury activation problem (possible fix?)

    When I am in a battle and try to use shadowfury, sometimes when I press the key the designation circle will click on and off. Other times it will behave correctly. Of course it misbehaves most often in those critical situations.

    Is this a common problem or am I the only lucky one?

    On a side note: it does not do this when I cast Rain of Fire or Blizzard (on mage) or Force of Nature (on druid).

  2. #2

    Re: shadowfury activation problem

    Hunter flare behaves the same way, it's just something with the way they programmed them.

  3. #3

    Re: shadowfury activation problem

    i have had the same problem

  4. #4

    Re: shadowfury activation problem

    Quote Originally Posted by rboa
    When I am in a battle and try to use shadowfury, sometimes when I press the key the designation circle will click on and off. Other times it will behave correctly. Of course it misbehaves most often in those critical situations.

    Is this a common problem or am I the only lucky one?

    On a side note: it does not do this when I cast Rain of Fire or Blizzard (on mage) or Force of Nature (on druid).
    Do not try to move the camera with your mouse if you have the spell active and ready to fire... in all seriousness thats the only thing I could think of. If you do so, it will go away. If that isn't the problem, I have no idea... I haven't noticed that problem.

  5. #5

    Re: shadowfury activation problem

    Quote Originally Posted by wildmandooby
    Do not try to move the camera with your mouse if you have the spell active and ready to fire... in all seriousness thats the only thing I could think of. If you do so, it will go away. If that isn't the problem, I have no idea... I haven't noticed that problem.
    I thought I was confusing it with trying to move the camera. Since then I have been real careful to not do the camera movement. The bad news is it will happen even when I don't move (or touch) the mouse.

    Now that you mention it Devildrive, it does behave like that on hunter flare. Since that is not critical I automatically recast it without even realizing.

  6. #6

    Re: shadowfury activation problem

    I notice this as well. It seems to occur when you are chain casting nukes and you attempt to throw in a SF.
    Perhaps if you had launched an incinerate or insta-SB and you hotkey a SF, during the travel time, it may go away when the bolt/incinerate actually lands.

    Currently at work so ill need to check later, but it doesnt occur when you are not being pressured.

  7. #7

    Re: shadowfury activation problem

    For me it isn't a global cooldown problem. The circle for the explosion comes on then turns immediately off.

  8. #8

    Re: shadowfury activation problem

    probably cos ur are spamming the button...

    nothing hard to understand u press the button once the circle thing comes up and u click on the spot to cast...

    u press the button again you "cancel" the spell and the circle thing is gone...

    wat is so hard to understand there ?

  9. #9

    Re: shadowfury activation problem

    Quote Originally Posted by noobj
    probably cos ur are spamming the button...

    nothing hard to understand u press the button once the circle thing comes up and u click on the spot to cast...

    u press the button again you "cancel" the spell and the circle thing is gone...

    wat is so hard to understand there ?
    No button spamming involved :

    With my hand off the mouse, one of three things will happen when i click the SF key:
    1) it works (makes the circle on the ground and it stays there)
    2) the circle flashes (appears and immediately disappears)
    3) nothing happens (this only happens after 2)

    While the problem is most common while fighting, it can happen anywhere (for example: testing it in shatt)

  10. #10

    Re: shadowfury activation problem


    Now that you mention it Devildrive, it does behave like that on hunter flare. Since that is not critical I automatically recast it without even realizing.
    [/quote]

    I think it's critical when it means the rogue getting away or getting the jump or you getting locked down for 10 seconds. Silly design flaw though, should work like hurricane or force of nature or rain of fire.

  11. #11

    Re: shadowfury activation problem

    This works MUCH, MUCH better for me.
    I made a simple macro:

    Code:
    #showtooltip Shadowfury
    /cast Shadowfury
    I know it should do the same thing, but it has almost eliminated the error. ;D

  12. #12

    Re: shadowfury activation problem

    Quote Originally Posted by rboa
    This works MUCH, MUCH better for me.
    I made a simple macro:

    Code:
    #showtooltip Shadowfury
    /cast Shadowfury
    I know it should do the same thing, but it has almost eliminated the error. ;D

    Nice, definitely will try it when i get home tonight : :


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •