1. #1

    F'd up graphic card.

    Hey there it's like my 3rd thread here about my graphic card,(GeForce GT220) and im annoyed as hell. Basically since i remember i had problems with drivers, and shit. When i thought i fixed all of them i downloaded newest driver from Nvidia (http://www.nvidia.com/object/win7-wi...river-all.html) and when i started installing it thath's what i got

    And please this is serious coz i cant do anything, hopefully someone will help.
    i am boycotting wow until i get to play protoss

  2. #2
    Moderator Cilraaz's Avatar
    Join Date
    Feb 2009
    Location
    PA, USA
    Posts
    9,062
    Make sure you fully remove your video drivers first. Go into Control Panel, click the drop down arrow next to Display Adapters, right click your video card, and select uninstall. Reboot your computer, and then re-run the driver installation.

  3. #3
    Stood in the Fire Erik765's Avatar
    Join Date
    Jan 2010
    Location
    Spokane, WA
    Posts
    371
    Have you tried downloading the driver file again? Sounds like it might be corrupt. The file should be around 155mb when finished downloading.
    Also, you are using Win7 x64 and not 32 bit correct?

  4. #4
    Pit Lord Dethh's Avatar
    Join Date
    Mar 2010
    Location
    Jersey
    Posts
    2,459
    You are downloading drivers for the 64 bit OS I hope you have 64 and not 32. Also you can always go back to device manager and roll back the drivers to the previous.

    @ Cilraaz: I know it will help to uninstall the drivers but doesn't nvidia not require you to do that, won't it just overwrite?

  5. #5
    Vista 64 bit, and i tried uninstalling the drivers through control panel, then installing the drivers and the same error, tried the Nvidia forums but they're under maintenance.
    i am boycotting wow until i get to play protoss

  6. #6
    Moderator Cilraaz's Avatar
    Join Date
    Feb 2009
    Location
    PA, USA
    Posts
    9,062
    Quote Originally Posted by Dethh View Post
    @ Cilraaz: I know it will help to uninstall the drivers but doesn't nvidia not require you to do that, won't it just overwrite?
    Nope. nVidia drivers are well known for being pains in the asses when the previous driver isn't uninstalled properly.

    Quote Originally Posted by arczi68 View Post
    Vista 64 bit, and i tried uninstalling the drivers through control panel, then installing the drivers and the same error, tried the Nvidia forums but they're under maintenance.
    Download Driver Cleaner Pro, download a new copy of the updated driver (being sure to delete the old one, so it doesn't just pull the potentially bad copy from your downloads folder), uninstall your video drivers via Control Panel (both Device Manager and Add/Remove Programs or whatever it's called in Vista), reboot into safe mode, run Driver Cleaner Pro, use it to remove all traces of all nVidia drivers, reboot, and install the new driver.
    Last edited by Cilraaz; 2010-06-21 at 08:02 PM. Reason: Clarification.

  7. #7
    Pit Lord Dethh's Avatar
    Join Date
    Mar 2010
    Location
    Jersey
    Posts
    2,459
    Does the driver CD have that utility?

  8. #8
    Driver Cleaner Pro was deleted from the website and what they recommend as an alternative doesn't work. Downloading new driver right now, and gonna try install it again
    EDIT: works now.
    EDIT2: in my remove/add programs which one do i remove: Nvidia Drivers, Nvidia Physx or Nvidia 3D stereoscopic driver?
    Yes i'm stupid.
    EDIT3: Ran the computer in safe mode, cleaned my drivers tried installing the new drivers and guess what? The same error.
    EDIT4: OMFG did it again and IT WORKS OMIGOD. CILRAAZ I LOVE YOU!
    Last edited by arczi68; 2010-06-22 at 03:11 PM.
    i am boycotting wow until i get to play protoss

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •