1. #1
    Epic! Riboe's Avatar
    Join Date
    Feb 2010
    Location
    Boubouille's Ear.
    Posts
    1,675

    Question Massive FPS drop when raiding (both 10&25 mans)

    Okay, I would have posted this in the 'Interface & Macros' forum, since I though it was an addon causing the problems, but I've figured out, it isn't.

    So, my problem is:
    In every raid (Both 10 and 25 man), my FPS drops from 40-60 down to something in between 0-1... I've disabled all my addons, graphics on the lowest and it's still happening.
    This make me think it's either my computer or my WoW installation that's messed up.
    My computer should easily be able to handle WoW, and I run with about 60 FPS on maxed settings, in a non-raiding environment..

    My specs:
    OS: Windows 7 Home Premium x64
    CPU: Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz (8 CPUs)
    Screen size: 1920x1080 (32bits)
    Video card: NVIDIA GeForce GT 230
    RAM: 8192 MB


    This has been going on for months and I haven't been able to fix it. I'm pretty good at searching information, but I've failed on this particular topic. :/
    So now I've come to MMO Champion, in hope that someone will have the answer to my prayer.
    What could I possibly do to fix it?
    I'm gonna reinstall the game in a couple of days, unless someone here manage to help me out.
    Thanks!
    Quote Originally Posted by Boubouille View Post
    AHAHAHAHAHAHHAHAHAHAHAHAHAHAHAHAHA YOU'RE FUCKED. (Yes, it's my forums, I'm allowed to do that)

  2. #2
    Video card is weak. step up to something like a gts 250, GTX 260.I would get a better video card for that resolution and go into the bios and make sure your pci-e slot is running at x16. Also run CPU-Z and real temp to check for temperatures. what kind of case are you running? how many fans? stock cooling? provide more information. start>run>type "dxdiag" and post the information here.

  3. #3
    I'd guess really outdated graphics drivers. Old Nvidia drivers (especially) cause all kinds of glitches, crashes and slowdowns around the game.
    Never going to log into this garbage forum again as long as calling obvious troll obvious troll is the easiest way to get banned.
    Trolling should be.

  4. #4
    Update the GPU drivers. If the problem doesnt get fixed, try another game. If the same thing happens there there might be something wrong with your hardware. If it only happens with wow try using the wow repair tool

  5. #5
    Epic! Riboe's Avatar
    Join Date
    Feb 2010
    Location
    Boubouille's Ear.
    Posts
    1,675
    Quote Originally Posted by Hotsforyou View Post
    Video card is weak. step up to something like a gts 250, GTX 260.I would get a better video card for that resolution and go into the bios and make sure your pci-e slot is running at x16. Also run CPU-Z and real temp to check for temperatures. what kind of case are you running? how many fans? stock cooling? provide more information. start>run>type "dxdiag" and post the information here.
    My specs are just fine... I have a laptop with much worse specs, and it's able to run Wow with no problems at all...

    Quote Originally Posted by vesseblah View Post
    I'd guess really outdated graphics drivers. Old Nvidia drivers (especially) cause all kinds of glitches, crashes and slowdowns around the game.
    Stupid me!.. How oculd I forget to update my drivers?! :O Trying that now - hopefully it works

    Quote Originally Posted by Sir Slack A Lot
    Update the GPU drivers. If the problem doesnt get fixed, try another game. If the same thing happens there there might be something wrong with your hardware. If it only happens with wow try using the wow repair tool
    Only happens when playing WoW.. Will run the repair tool, if updating the drivers won't work.

    Thanks to the above posters!
    I'm still open for suggestions, in case none of the above works
    Quote Originally Posted by Boubouille View Post
    AHAHAHAHAHAHHAHAHAHAHAHAHAHAHAHAHA YOU'RE FUCKED. (Yes, it's my forums, I'm allowed to do that)

  6. #6
    na, your CPU only has 4 Cores, but each one can handle 2 threads at a time, therefore windows shows you 8 cores (Hyperthreading).

    WOW doesn't really profit from more Cores that much, I'd rather deactivate Hyperthreading and go with faster core clocking.


    The video card doesn't fit to the rest of the system, it's like havin a Ferrari with bicycle wheels. Should be enough for WOW though.



    Have you set shadows to full? try lowering those, it will be a massive performance upgrade.

  7. #7
    Epic! Riboe's Avatar
    Join Date
    Feb 2010
    Location
    Boubouille's Ear.
    Posts
    1,675
    Quote Originally Posted by Khalelia View Post
    Have you set shadows to full? try lowering those, it will be a massive performance upgrade.
    As you can see in my original post, I had tried with all settings on the lowest possible, still it didn't help.

    But the solution was simple.. Update my graphics drivers. (How.. How could I forget about that?! Stupid me...) But thanks for the help everybody and especially Vesseblah
    Quote Originally Posted by Boubouille View Post
    AHAHAHAHAHAHHAHAHAHAHAHAHAHAHAHAHA YOU'RE FUCKED. (Yes, it's my forums, I'm allowed to do that)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •