Thread: Disable sound

  1. #1
    Titan Frozenbeef's Avatar
    Join Date
    Aug 2009
    Location
    Uk - England
    Posts
    11,163

    Disable sound

    Any way to disable the following sound effects without disabling anything else?

    the sound mounts make...specifcally the engineer land mount and the celestial steed >.<

    the thud sound when changing targets?

    thx

    ps. the reason i want to disable them is just so i can hear music, ambience , boss's yelling

  2. #2
    That would probably involve changing game files, or at least overriding them using the Data folder.
    You're entering a grey zone when it comes to legality there - if Blizzard finds out, you're gone. They probably won't though.
    UI & AddOns expert | Interface & Macros moderator - My work

  3. #3
    Actually, "overriding them" by creating a Data folder is perfectly fine. It's been suggested without Blizzard disapproval numerous times in the UI & Macros forum since vanilla WoW.

    1. Create an empty wav file.
    2. Using a MPQ extractor, you need to (A) find the relevant sound effect wav file in the MPQ archives and (B) mirror the directory structure into your own Data folder.
    3. Copy empty wav file into appropriate sub directory, renaming the file to the actual sound affect.

    This is a brief explanation. Search around the official WoW forums, you'll find in-depth explanation.

    I've been doing this since vanilla to remove spell spam effects, with no problems.

  4. #4
    Titan Frozenbeef's Avatar
    Join Date
    Aug 2009
    Location
    Uk - England
    Posts
    11,163
    gearscorethis ..that souds great and exactly what i want...but my computer knowledge is limited to cut and paste :P

    ---------- Post added 2010-07-20 at 08:28 PM ----------

    Bah just gonna leave sound off and hope they make advanced sound options to disale combat sound in cataclysm >.<

  5. #5
    What you do is just create a blank file in these folders with these exact file names. So for example in your WoW folder, make a new folder called Sound then in that, make folders for Vehicles and Interface etc... and put these empty files in those places and WoW will use the local version of the file instead of calling on the one from the game.

    The sound for changing targets is:

    Sound\Interface\iSelectTarget.wav
    also
    Sound\Interface\iDeselectTarget.wav
    I don't have the Chopper mount myself so I can't tell for sure if this is the sound, but from the filename it probably is.

    Sound\Vehicles\MotorcycleVehicle\MotorcycleVehicleJumpStart1.wav
    Sound\Vehicles\MotorcycleVehicle\MotorcycleVehicleJumpStart2.wav
    Sound\Vehicles\MotorcycleVehicle\MotorcycleVehicleJumpStart3.wav
    Sound\Vehicles\MotorcycleVehicle\MotorcycleVehicleStand.wav
    Sound\Vehicles\MotorcycleVehicle\MotorcycleVehicleWalkRun.wav
    There are no sounds for the steed.

    MMO champ is putting a space in the filenames with the MotorcycleVehicleJump...etc... it is all one word, no spaces.

    Gershuun @ Borean Tundra US - Interface & Macros Moderator

  6. #6
    The celestial steed does in fact have sounds, but they are less obvious since at least the flapping sounds are shared with that of the phoenix, so would mute those also. A minor inconvenience, unless you happen to own that already.
    Taken from Silent Celestial @ Wowinterface.

    \Sound\Creature\Phoenix\PhoenixWingFlap1.wav
    \Sound\Creature\Phoenix\PhoenixWingFlap2.wav
    \Sound\Creature\Phoenix\PhoenixWingFlap3.wav
    \Sound\Creature\Phoenix\PhoenixWingFlap4.wav
    I am not currently able to identify the horse sounds it uses, but that should be a start at least.

    Edit: - Through an addon AudioX II I have been able to locate several other sounds relating to the Celestial Steed.

    \Sound\Creature\CelestialHorse\CelestialHorse_MountSpecial_01.wav
    \Sound\Creature\CelestialHorse\CelestialHorse_MountSpecial_02.wav
    \Sound\Creature\CelestialHorse\CelestialHorse_MountSpecial_03.wav
    Plus the "wound" sounds, from you taking damage while mounted

    \Sound\Creature\CelestialHorse\CelestialWound_01.wav
    \Sound\Creature\CelestialHorse\CelestialWound_02.wav
    \Sound\Creature\CelestialHorse\CelestialWound_03.wav
    Remove the spaces in the wav - odd sideffect of the quote tag adding them where unecessary.
    Last edited by ComputerNerd; 2010-07-21 at 06:57 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •