1. #1

    WoW lagging in Windows 7

    I recently installed Windows 7, and even more recently re-activated my WoW account. Just a few minutes after I started playing, my latency was above 2000 and never dropped back down. I'm assuming that it's some sort of issue with the game rather than my connection since web browsing, other games, and the Blizzard Downloader work great.

    Anyone had the same issue and know a fix for it? Or is WoW just not good with Windows 7 yet and I just have to deal with it?

    Also, I feel like what I've said is very vague, so feel free to ask questions regarding my system and blah blah.

  2. #2
    Ain't got nothing to do with Windows version. Check out the stickies for fixing lag for starters.

    Also, if you use crappy wireless connection (satellite or 3G) that's pretty much the best you can get.
    Never going to log into this garbage forum again as long as calling obvious troll obvious troll is the easiest way to get banned.
    Trolling should be.

  3. #3
    Well, to be quite frank with you.

    1: Check your package loss while inside WoW. When downloading programs you can have a fast download rate, yet while streaming, as most multiplayer games are, some internet providers gives you huge package losses, thus resulting in a bad experience.

    2: It might be something with your drivers, are you sure you've updated Graphics, Internet, etc etc to the newest? If not, go do it.

    3: I can only say, if it ran well with XP it will run well with Win 7. I am currently sitting on Win 7, having a wonderful time playing WoW, Starcraft, HoN, etc etc

  4. #4
    My WOW and W7 play very well together. I suspect there is something else going on here.
    http://us.battle.net/wow/en/characte...gwraith/simple (8/8 H T13; 7/7 H T12 - F.U. Ragnaros)
    Quote Originally Posted by kumduh View Post
    @Wingwraith: You can haz a point too, but only because you admit you're a tool!

  5. #5
    Thanks for the quick replies.

    Leatrix fixed my problem. I'm sitting in Dalaran now with 80 ms, so I'm pretty hopeful that it'll keep working.

    And sorry about missing the stickies. Didn't think about that first.

  6. #6
    I'm a big fan of Leatrix. My average latency was cut in half after running it. I used to average around 150-300ms prior, and post it averages around 75-100ms.
    http://us.battle.net/wow/en/characte...gwraith/simple (8/8 H T13; 7/7 H T12 - F.U. Ragnaros)
    Quote Originally Posted by kumduh View Post
    @Wingwraith: You can haz a point too, but only because you admit you're a tool!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •