1. #1

    Razer Naga mouse problems

    Good evenning, computer forum.
    First, let me apologize for my bad grammar and punctuation - as a foreigner- i'm still working on learn how to writte english properly.

    Then, the real issue.
    I've recently purchased the Naga Mouse from Razer, and i've come up with a series of issues.

    1.After some seconds of use, the cursor simply starts to "teleport" to the bottom of the screen.
    2.The cursor simply stops moving for a couple of seconds, and then simply returns to it's normal behavior of "teleporting".

    Has anyone experienced this?
    I've googled some of this issue and it appears that nobody has a real solution for it.
    Most answers i've read or received so far is "Don't buy Razer mouses".

    Thank you for the attention, and your time.

  2. #2
    If it's a recurring issue that multiple people are having, I'd guess drivers myself. I would make sure you have the latest software downloaded from the Razer website, and shoot an email to their tech support if it keeps happening. I've had that issue on some work computers on occasion, and there doesn't seem to be a reason for it (not using a Razer mouse, obviously).

  3. #3
    Dreadlord Kyocere's Avatar
    Join Date
    Oct 2009
    Location
    New Jersey
    Posts
    756
    Quote Originally Posted by ant1pathy View Post
    If it's a recurring issue that multiple people are having, I'd guess drivers myself. I would make sure you have the latest software downloaded from the Razer website, and shoot an email to their tech support if it keeps happening. I've had that issue on some work computers on occasion, and there doesn't seem to be a reason for it (not using a Razer mouse, obviously).
    Like he said make sure all your drivers are correct and try re-installing the software. If you continue to have the problem swap it out with another. I just got my naga on Thursday and I have had zero issues with it. I even take it to work everyday because I love it so much.

  4. #4
    The Patient Aranor's Avatar
    Join Date
    Aug 2010
    Location
    Ireland
    Posts
    302
    Could it be the surface you're using your mouse on? Hard / soft is probably messing the laser up?

    Just a quick-fire shot at it.

  5. #5
    hey all, i have had the razor naga for a while and its been great but recently i have had some issues.

    Sometimes the mouse just picks a line from right to left of the screen and stays there (without moving up or down) no matter how i move with the mouse, for example if i move my hand to the bottem right my mouse on screen goes perfectly right across the screen.

    Also my mouse seems to double click randomly as well, which is a problem since im a fan of SC2 as well =P and just general usage, ill try re downloading some drivers and such but i wanted to see your thoughts on the situation as well.

    And advice would be great =D

  6. #6
    Quote Originally Posted by dangergnome View Post
    hey all, i have had the razor naga for a while and its been great but recently i have had some issues.

    Sometimes the mouse just picks a line from right to left of the screen and stays there (without moving up or down) no matter how i move with the mouse, for example if i move my hand to the bottem right my mouse on screen goes perfectly right across the screen.

    Also my mouse seems to double click randomly as well, which is a problem since im a fan of SC2 as well =P and just general usage, ill try re downloading some drivers and such but i wanted to see your thoughts on the situation as well.

    And advice would be great =D
    I am having the EXACT same problem as this. As i am moving the mouse it will randomly stop moving up and down and only allow me to move left to right in a line. I've sat there and just moved the mouse in a circle for a couple minutes and it will continue to do the horizontal line movement for about 20 sec before allowing me to move normally again. I am able to move the mouse normally for about 5 minuntes before the horizontal movement kicks back in.

  7. #7
    I've had the exact same problem as the last couple of users where the mouse cursor would get stuck and hit an invisible wall on my screen or attach itself to an invisible line and only ride that line no matter how you move the mouse.

    Anyone find a resolution yet?

  8. #8
    I had the same problem, but i went on razers website and i downloaded the _Firmware updater_ make sure to follow ever instruction and it will be fixed!
    Last edited by Reazzor; 2011-12-02 at 02:52 PM.

  9. #9
    On the topic of Razer... does it really have that annoying scrolling/acceleration feature?

  10. #10
    I had the same problem on one of my naga's. Ended up killing that one on accident - point of advice: don't let mouse cords rub agains raw particle board for extended periods of time, it will fray and murder the cord Either way, I fixed mine by updating the software/firmware stuffs, and also did a bit of mouse surgery, and found two small pieces of dog hair that had gotten caught in the sensor thingy on the bottom - between the software and taking those out, mouse went back to normal. Don't know if any of that helps or just makes me look a little retarded lol :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •