Thread: New Build

  1. #1
    High Overlord Ghostlore's Avatar
    Join Date
    May 2008
    Location
    Virginia
    Posts
    151

    New Build

    I'm finally making the change from playing on a MacBook Pro laptop to building an actual PC desktop to play WoW on. I'm planning on buying with the Black Friday Sale, but this is my set-up.

    Comments, Concerns, Input...

    Case = Cooler Master CAC-T05-UW
    CPU = Intel Core i5-650 Clarkdale 3.2GHz
    Motherboard = GIGABYTE GA-H55M-UD2H LGA 1156
    Memory = Kingston HyperX 8GB (4 x 2GB) 240-Pin DDR3 1600
    Hard Drive = Western Digital Caviar Black WD1001FALS 1TB
    Video Card = ASUS ENGTX460 DirectCU TOP/2DI/1GD5 GeForce GTX 460
    Sound Card = Creative Sound Blaster Audigy SE 7.1
    CD Rom = ASUS Black 24X DVD+R
    Cooling Fan = COOLER MASTER RR-H101-22FK-RI
    Power Supply = COOLER MASTER Silent Pro M700 RS-700-AMBA-D3 700 Watts
    Hello.

    Sexy Sig by: Axalicious
    Armory

  2. #2
    Pit Lord Dethh's Avatar
    Join Date
    Mar 2010
    Location
    Jersey
    Posts
    2,459
    The processor you have listed is 2 cores get the 4 core i5-760

  3. #3
    Yes get an i5-760. Also change the motherboard to a P55 chipset. You have H55 now which are made for onboard graphics and won't be good at all because you'll have a GTX 460.
    8GB of RAM is going to be completely useless if you're using it only for gaming, 4GB is all you need now.
    You can take a sound card if that's important to you, but modern motherboards have really good onboard sound cards.

  4. #4
    The Lightbringer Asera's Avatar
    Join Date
    Aug 2008
    Location
    This side of an imaginary line in the sand
    Posts
    3,740
    If you're going to get a sound card, at least get an X-Fi. An Audigy won't be much better than current onboard offerings... and actually might even be worse. The Audigy line is rather old.
    Node 304 | i7 3770 | H77N WIFI | 2x4GiB HyperX 1600 | 2x512GB MX100 | MSI GTX970 4GiB | U2711 | 6GV2 | Naga Hex Wrath | Yamaha RX-V550 | Win8.1 Pro
    15" Retina MBP | i7 4960HQ | 16GiB 1600 | 512GB PCIe SSD | IRIS Pro + GT750M | G700S | OSX 10.10

  5. #5
    Fluffy Kitten llDemonll's Avatar
    Join Date
    Apr 2008
    Location
    Washington
    Posts
    6,582
    Sound cards are useless unless you are doing something profession with sound. Save the money and put it towards the i5 750/760
    "I'm glad you play better than you read/post on forums." -Ninety
    BF3 Profile | Steam Profile | Assemble a Computer in 9.75 Steps! | Video Rendering Done Right

  6. #6
    High Overlord Ghostlore's Avatar
    Join Date
    May 2008
    Location
    Virginia
    Posts
    151
    I have upgraded my list to =

    Case = Cooler Master CAC-T05-UW
    CPU = Intel Core i5-760 Lynnfield 2.8GHz LGA 1156 95W Quad-Core
    Motherboard = ASUS P7P55 LX LGA 1156 Intel P55 ATX Intel Motherboard
    Memory = Kingston HyperX 4GB (2 x 2GB) 240-Pin DDR3 1600
    Hard Drive = Western Digital Caviar Black WD1001FALS 1TB
    Video Card = ASUS ENGTX460 DirectCU TOP/2DI/1GD5 GeForce GTX 460
    CD Rom = ASUS Black 24X DVD+R
    Cooling Fan = CORSAIR Cooling Hydro Series CWCH50-1 120mm High Performance CPU Cooler
    Power Supply = COOLER MASTER Silent Pro M700 RS-700-AMBA-D3 700 Watts
    Last edited by Ghostlore; 2010-11-22 at 03:03 PM.
    Hello.

    Sexy Sig by: Axalicious
    Armory

  7. #7
    Brewmaster Reguilea's Avatar
    Join Date
    Jun 2010
    Location
    Finland
    Posts
    1,425
    Looks good. But no need for 4GB of IDLE ram. Unless you have an explanation.
    Just get 2x 2GB.

    4670k @ 4.4 - Kingston HyperX 16GB (4x 4096MB @ 1333mhz) - Zotac GTX 680
    h20 620 V4 push/pull - Fractal Design Pearl R4 - Samsung 830 64GB - Surround 5040x1050
    -

  8. #8
    High Overlord Ghostlore's Avatar
    Join Date
    May 2008
    Location
    Virginia
    Posts
    151
    That was a typo. I only am getting 4GB
    Hello.

    Sexy Sig by: Axalicious
    Armory

  9. #9
    Fluffy Kitten llDemonll's Avatar
    Join Date
    Apr 2008
    Location
    Washington
    Posts
    6,582
    Are you overclocking?
    "I'm glad you play better than you read/post on forums." -Ninety
    BF3 Profile | Steam Profile | Assemble a Computer in 9.75 Steps! | Video Rendering Done Right

  10. #10
    Pit Lord Fuger's Avatar
    Join Date
    Jul 2009
    Location
    In A Particle Accelerator
    Posts
    2,377
    ASUS ENGTX460 DirectCU TOP/2DI/1GD5 GeForce GTX

    On Newegg that is $210

    Save $20 and get better performance with:
    http://www.newegg.com/Product/Produc...82E16814121399

    Or wait for the 460's to drop in price. No point in buying out dated products for their full price.
    Quote Originally Posted by qu1rex View Post
    Across the pond, we stereotype the average US citizen as being quite dim-witted, albeit due to the poor education standards subject to them by their curriculum.
    Sad to know people think I am stupid.

  11. #11
    The Lightbringer Asera's Avatar
    Join Date
    Aug 2008
    Location
    This side of an imaginary line in the sand
    Posts
    3,740
    Quote Originally Posted by llDemonll View Post
    Sound cards are useless unless you are doing something profession with sound. Save the money and put it towards the i5 750/760
    I disagree. I've never heard onboard that can come close to pushing my speakers and headphones as good as my X-Fi. :s
    Node 304 | i7 3770 | H77N WIFI | 2x4GiB HyperX 1600 | 2x512GB MX100 | MSI GTX970 4GiB | U2711 | 6GV2 | Naga Hex Wrath | Yamaha RX-V550 | Win8.1 Pro
    15" Retina MBP | i7 4960HQ | 16GiB 1600 | 512GB PCIe SSD | IRIS Pro + GT750M | G700S | OSX 10.10

  12. #12
    High Overlord
    Join Date
    Oct 2010
    Location
    Finland
    Posts
    131
    Asera, what kind of sound system do you have then? If you got HiFi class headphones I might believe you, otherwise no.

  13. #13
    The Lightbringer Asera's Avatar
    Join Date
    Aug 2008
    Location
    This side of an imaginary line in the sand
    Posts
    3,740
    I have a pair of Sennheiser HD280s. For speakers though I only have a crappy 2.1 Altec Lansing system. Both sound much better on the X-Fi.

    ...and even my cheap 15 dollar skullcandy earbuds that I use for cycling sound better on an X-Fi than onboard...
    Node 304 | i7 3770 | H77N WIFI | 2x4GiB HyperX 1600 | 2x512GB MX100 | MSI GTX970 4GiB | U2711 | 6GV2 | Naga Hex Wrath | Yamaha RX-V550 | Win8.1 Pro
    15" Retina MBP | i7 4960HQ | 16GiB 1600 | 512GB PCIe SSD | IRIS Pro + GT750M | G700S | OSX 10.10

  14. #14
    Moderator Cilraaz's Avatar
    Join Date
    Feb 2009
    Location
    PA, USA
    Posts
    9,062
    Placebo effect? That's the best reasoning I can come up with. Either that or you're using some ancient on-board audio solution.

  15. #15
    Fluffy Kitten llDemonll's Avatar
    Join Date
    Apr 2008
    Location
    Washington
    Posts
    6,582
    You either have freakish ears or a motherboard that is old with bad onboard sound.
    "I'm glad you play better than you read/post on forums." -Ninety
    BF3 Profile | Steam Profile | Assemble a Computer in 9.75 Steps! | Video Rendering Done Right

  16. #16
    The Lightbringer Asera's Avatar
    Join Date
    Aug 2008
    Location
    This side of an imaginary line in the sand
    Posts
    3,740
    Quote Originally Posted by llDemonll View Post
    You either have freakish ears or a motherboard that is old with bad onboard sound.
    Asus M4A89GTD, Realtek HD Audio garbage. I use onboard for Vent and the X-Fi for everything else.
    At work, P7P55D LE with even worse VIA Vinyl crap.

    The only onboard I've used that came sort of close to sounding as good as a real DSP is the old nForce 2 SoundStorm audio. Everything else just sucks sucks and sucks more. :P

    But hey, that's me. I guess I have freakish hearing.
    Last edited by Asera; 2010-11-23 at 05:02 PM.
    Node 304 | i7 3770 | H77N WIFI | 2x4GiB HyperX 1600 | 2x512GB MX100 | MSI GTX970 4GiB | U2711 | 6GV2 | Naga Hex Wrath | Yamaha RX-V550 | Win8.1 Pro
    15" Retina MBP | i7 4960HQ | 16GiB 1600 | 512GB PCIe SSD | IRIS Pro + GT750M | G700S | OSX 10.10

  17. #17
    High Overlord
    Join Date
    Oct 2010
    Location
    Finland
    Posts
    131
    With that quality of listening equipment, there's either something with the drivers or the equalizer. You have some weird equalizer setup in use with the realtek because you can't possibly hear a difference with that setup.

  18. #18
    The Lightbringer Asera's Avatar
    Join Date
    Aug 2008
    Location
    This side of an imaginary line in the sand
    Posts
    3,740
    Believe me, I've played with the equalizer. I can't get onboard to match the quality of the X-Fi at all.
    Node 304 | i7 3770 | H77N WIFI | 2x4GiB HyperX 1600 | 2x512GB MX100 | MSI GTX970 4GiB | U2711 | 6GV2 | Naga Hex Wrath | Yamaha RX-V550 | Win8.1 Pro
    15" Retina MBP | i7 4960HQ | 16GiB 1600 | 512GB PCIe SSD | IRIS Pro + GT750M | G700S | OSX 10.10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •