1. #1

    Login Server Busy, Please Try Again

    Login Server Busy, Please Try Again
    Super quick news post about the server issues.
    Originally Posted by Lylirra (Blue Tracker)
    We're aware that many players are currently receiving the message "Login Server Busy, Please Try Again" whenever attempting to log into World of Warcraft. While we don't have an ETA for when this issue will be resolved, we're looking into it at this time and hope have everyone back in the game as soon as possible.

    In the meantime, in order to keep reports consolidated, we ask that you please keep posts related to this login issue in this thread. Duplicate threads will likely be locked and redirected here, or deleted completely.

    Thanks for your patience! As updates become available, we'll provide them in this thread.

  2. #2
    Is that why my lag is horrible...

  3. #3
    Herald of the Titans Abstieg's Avatar
    Join Date
    Apr 2010
    Location
    Boston, Massachusetts
    Posts
    2,900
    I assume this is also related to the "Your prepaid time is used up" message I'm getting. Their phone services said they have problems with their payment processing now too.
    The goddess in my avatar is Hayley Williams.

  4. #4
    Whew, finally a login error I'm not affected by!

  5. #5
    Quote Originally Posted by krazymagefunk View Post
    Is that why my lag is horrible...
    Login server being busy = in game lag, perfectly logical.

  6. #6
    Legendary! StayTuned's Avatar
    Join Date
    Mar 2011
    Location
    Europe
    Posts
    6,406
    Must be US Servers? EU works fine, for me at least

  7. #7
    I guess i picked a good day to play hookie

  8. #8
    ugh, just great.. I wish i were unaffected.

  9. #9
    Immortal Bombkirby's Avatar
    Join Date
    Aug 2009
    Location
    USA - Boston, MA
    Posts
    6,995
    Quote Originally Posted by StayTuned View Post
    Must be US Servers? EU works fine, for me at least
    US server is fine for me....first time logging in today though so I dunno if it WAS bad before.

  10. #10
    Quote Originally Posted by Bombkirby View Post
    US server is fine for me....first time logging in today though so I dunno if it WAS bad before.
    It has to do with people who were billed on the 18th, for some reason the system has gotten hosed up and now everyone who got billed then has fallen out of their subscription period and shows "pending" on their account.

  11. #11
    Herald of the Titans Abstieg's Avatar
    Join Date
    Apr 2010
    Location
    Boston, Massachusetts
    Posts
    2,900
    Quote Originally Posted by jaymzkerten View Post
    It has to do with people who were billed on the 18th, for some reason the system has gotten hosed up and now everyone who got billed then has fallen out of their subscription period and shows "pending" on their account.
    Happened to me, also the 18th, working for about half an hour now though.
    The goddess in my avatar is Hayley Williams.

  12. #12
    I was billed on the 19th and it happened to me, but it seemed to happen later than the ones that were billed on the 18th. It went out for me sometime between 3pm and 6pm CST.

    Edit: Still doesn't work for me btw.

    This is a stretch, but surely Blizz doesn't use Amazon for hosting stuff like this and it's just a coincidence that they're having trouble too?

    http://www.theregister.co.uk/2011/04...s_spans_zones/

  13. #13
    billed on the 11th and im having the same problem, been on the phone to blizzard and they seemed to reckon it had something to do with BT. Apparently 95% off people with the problem were on a BT line :S

  14. #14
    god blessed im working.

  15. #15
    Blademaster tobia's Avatar
    Join Date
    Apr 2011
    Location
    new hampshire
    Posts
    29
    my acct is showing active still i dont get billed till 24 but i cannot log in what gives

  16. #16
    OMFG I WANT MY WARCRAFT!!! Sorry, I had to get that out.

    Signed,
    Sartharion

  17. #17
    Bloodsail Admiral Mixxy Scratch's Avatar
    Join Date
    Jun 2010
    Location
    Same ol', same ol'.
    Posts
    1,023
    Quote Originally Posted by Sartharion View Post
    OMFG I WANT MY WARCRAFT!!! Sorry, I had to get that out.

    Signed,
    Sartharion
    You realize that this thread is from like 4 or 5 days ago, right? The issue has long since be resolved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •