1. #1

    Headset Microphone has Stopped Working

    I don't know if anyone here can help but my issue is that my headset microphone isn't working. I am using the Steelseries Siberia V2s that use the 3.5mm headphone/microphone jack. They have been working fine ever since I bought them but for some reason they just stopped on me. I've tried unplugging them, cleaning the jack, messing with the sound options in control panel, downloading a new audio driver, system restoring, plugging them into another location on the pc, checking to see if the front panel connectors were still plugged into the motherboard, checking if it was muted or not but nothing. I have tried them out on my laptop and they worked perfectly so that can only mean something is up with my desktop. The pc does pick up when I plug or unplug the mic but for some reason the microphone does not pick up any voices. All you can hear is static and sometimes my friends would say they heard the music playing from itunes as clearly as if it was playing through their own speakers. I can confirm that a USB desktop microphone and a rock band microphone works so it must be something with the headphone jack. I've tried messing with the options with no avail can anyone help me find out what the issue is and how I can get my headset working again.

    Testing the mic in Skype also shows that the static happens even if the mute switch is on or off.
    Last edited by Aftersight; 2011-05-16 at 04:09 AM.

  2. #2
    Pandaren Monk DarkXale's Avatar
    Join Date
    Sep 2008
    Location
    Sweden
    Posts
    1,786
    You may have accidentally set another device as the default input, specifically to a recording device that 'records' your speaker output in the Windows audio settings.

  3. #3
    I don't think so as it only shows 1 device that I could use to record with.

  4. #4
    Bloodsail Admiral Kulthor's Avatar
    Join Date
    Mar 2011
    Location
    Tennessee
    Posts
    1,220
    Possibly a short as well try moving the cords while listening to something.
    It's happened to like 13 out of my 15 or so mics... lol.

  5. #5
    Quote Originally Posted by Kulthor View Post
    Possibly a short as well try moving the cords while listening to something.
    It's happened to like 13 out of my 15 or so mics... lol.
    A short in my headset? I've tried and confirmed that it works perfectly in my laptop.

  6. #6
    Is the Rock band microphone plugging into the same 3.5mm port? Also, not sure if you're using onboard sound or a dedicated sound card, but if you're using like a SoundBlaster card for example I've had an issue before where the "flex jack" needed to be switched back to Microphone.

    Proud Officer of Gwen Stefani on the Blackhand-US Realm

  7. #7
    Quote Originally Posted by spacechicken_bh View Post
    Is the Rock band microphone plugging into the same 3.5mm port? Also, not sure if you're using onboard sound or a dedicated sound card, but if you're using like a SoundBlaster card for example I've had an issue before where the "flex jack" needed to be switched back to Microphone.
    The rock band mic uses a USB port and I do not have another 3.5mm headsets/microphone to test the port on my PC. I have tried the front, rear, and extra ports that i have on my keyboard with all of them producing the same static sound in recording.

  8. #8
    Bloodsail Admiral Kulthor's Avatar
    Join Date
    Mar 2011
    Location
    Tennessee
    Posts
    1,220
    Quote Originally Posted by Aftersight View Post
    A short in my headset? I've tried and confirmed that it works perfectly in my laptop.
    Very odd then... the only thing I can really see wrong then is you don't have them setup right in your Playback/record devices... If that's not it something has to be screwed up.

  9. #9
    This baffles me, since other mics work on your PC, and your steelseries mic works on your laptop. So it's probably not a hardware issue. Only possibility I can see is the jack being screwed, but that sounds unlikely aswell.

    GL with it, sadly I cannot help :<

  10. #10
    Quote Originally Posted by Aftersight View Post
    The rock band mic uses a USB port and I do not have another 3.5mm headsets/microphone to test the port on my PC. I have tried the front, rear, and extra ports that i have on my keyboard with all of them producing the same static sound in recording.
    So just asking again, are you using onboard or a dedicated card for your computer audio?

    Proud Officer of Gwen Stefani on the Blackhand-US Realm

  11. #11
    This is the first issue that I could not over come with the power of google fu so this one has got me quite stumped.

    ---------- Post added 2011-05-15 at 11:30 PM ----------

    Quote Originally Posted by spacechicken_bh View Post
    So just asking again, are you using onboard or a dedicated card for your computer audio?
    Oh sorry forgot to answer that question, I am using the onboard sound card that came on my msi gd-65 motherboard.

  12. #12
    Hmm, well if it were me the next step I'd try is another 3.5mm headset microphone... good luck mate!

    Proud Officer of Gwen Stefani on the Blackhand-US Realm

  13. #13
    Quote Originally Posted by spacechicken_bh View Post
    Hmm, well if it were me the next step I'd try is another 3.5mm headset microphone... good luck mate!
    Yeah, I wish i hadn't thrown away my old one X_X

    ---------- Post added 2011-05-16 at 11:30 PM ----------

    Ok I had bought a $20 analog mic that uses the same input jacks as my siberias and they worked. WTF what is it that is making my siberias not work and these $20 walmart headsets work on my system? I have tried to play around and see if there was anything I had changed in the sound/audio settings in the control panel but nothing worked! Someone please give me some ideas as I know its not a bad microphone port but some settings on my PC that is preventing my microphone from working.
    Last edited by Aftersight; 2011-05-17 at 04:30 AM.

  14. #14
    please anyone? ;(

  15. #15
    Check with anyother system whether microphone is working

  16. #16
    Quote Originally Posted by Tirupati darshan booking View Post
    Check with anyother system whether microphone is working
    Yes, I have and it works like I said in the opening post.

  17. #17
    Do you have something other than Skype you can test against? Vent or TS perhaps? Would be good if you could eliminate a software issue as your problem with the mic.

  18. #18
    ive tested in vent, sound recorder, and fraps. the new mic works my siberias don't.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •