1. #1
    Pit Lord HBpapa's Avatar
    Join Date
    Nov 2010
    Location
    Newport Mesa, Ca
    Posts
    2,417

    SW: Death Glyph problem.

    I've continued to level my priest and got him to level 50 and with it my second set of glyphs. Went with Spirit Tap (helps with mana at earlier levels for sure) as my first Prime so SW would be my second (huge dps boost and mana to boot).

    For some reason this isn't working about 80% of the time when in dungeons and i am not sure why. A mob will get down below and 25% and I will hit SW twice. Sometimes it works like I think it should...two successive attacks that result in a single killing blow, a hit and a then a killing blow, or just two hits (and about 1% of their health left).

    Unfortunately, most of the time my UI just blinks like I am locked out of that spell...kind of like the effect you get when "That spell is not ready yet"....and I cant get a single SW off and suffer dps/mana loss because of it. Makes it hard to not go OOM when in AoE pulls. Even if I wait till 24% on a boss (basically enough health that no way the group is going to kill him before I can hit SW twice) and use the spell I still get locked out of it.

    Am I using this spell wrong or is something a little buggy?


    EDIT:
    Happy face = Death. Didn't intend it but I like it.

  2. #2
    Mechagnome Kassina's Avatar
    Join Date
    Nov 2010
    Location
    Alingsås, Sweden
    Posts
    625
    I don't really get it. You mean when you use SW under 25% the attack like buggs out? The only thing I know is that when you press it when you have glyph and your target is under 25% it kinda reset before the gcd but can't use it after 1.5sec or whatever the gcd is now. but i always get 2 hits after 25% just spam it ^^

  3. #3
    Pit Lord HBpapa's Avatar
    Join Date
    Nov 2010
    Location
    Newport Mesa, Ca
    Posts
    2,417
    That is exactly what I'm doing....spamming it at <25%. But instead of actually performing the spell the UI just kind of locks up.

  4. #4
    Mechagnome Kassina's Avatar
    Join Date
    Nov 2010
    Location
    Alingsås, Sweden
    Posts
    625
    Well never heard of that problem. If you use some UI addon like ElvUI try to disable that or reinstall it.

  5. #5
    Not sure if this may be your problem, but I've noticed it works better, when using a key press than if you try to mouse it...if I mouse mine, it will sometimes not work, for either the first, or second cast....
    Last edited by Bluepoet; 2011-10-10 at 12:08 AM.

  6. #6
    If spamming it, sometimes it will hit twice w/that one gcd. I thought the same thing so i went thru the combat log and seen it did hit twice

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •