1. #1

    Unable To Open Archive File Gw2.dat

    It happened after I stopped downloading gw2 because my first disk was full, then I copypasted everything (.exe,.tmp,.dat) to another disk. Now when I start gw2.exe client, I get this error:

    -I deleted gw2 files.
    -deleted register files
    -tried to run as administrator
    Still the same problem.

    What's wrong?

    ---------- Post added 2012-04-25 at 11:27 PM ----------

    Please, anyone?

  2. #2
    Just a guess but are you sure the folder/files are not marked as read only? Also in most standard computer setups the D drive leter is reserved for the CD/DVD disk drive, why are you trying to run it from there or is the D drive an actual harddrive on your system?

    Who is John Galt?

  3. #3
    C = 30gb first
    D = 470gb second

    It works fine on C: (windows is located here)
    but it doesn't work on D: (error)

  4. #4
    I am Murloc! Mif's Avatar
    Join Date
    May 2009
    Tarnished Coast
    Try moving the dat file out of the folder
    Then run the exe. It should try to download the dat file again
    Then close the client, and move the old dat file back replacing the new one

  5. #5
    Hi Blapis, there are a few problems that can cause this issue.

    Try restarting your computer before doing any of this.

    Your virus checker may be interfering with the game, please exclude the Guild Wars 2 folder inside your virus checker program. If you do not know how to do this, go to the website of your virus program and research how. You could always disable your virus checker, but I don't recommend doing that.

    Never move a file while it's still downloading, all data on the internet is split into thousands of packets and then reassembled. When you interfere with downloading you can cause the file to be corrupt. There's a few ways to identify if you have a correctly "assembled" file. We have redundancy checks that compare the correctly assembled file to the corrupt file.

    However it is extremely impractical to compare a MD5 hash because the client consistently updates.

    Here are a few possible fixes before you delete anything:
    Make sure you are logged on the main administrator account.

    Open My Computer
    Open D:\
    Find Guild Wars 2
    Right Click the folder
    On the context menu, select properties.
    If Read Only is checked, uncheck it.
    Click Security Tab
    If you don't see this tab, then this is not the problem. It is disabled by default on Windows 7 Home Premium.
    If you see this tab, make sure you have complete control of the file.
    Click Advance settings for permissions, its on the second window below the user permissions.
    CLick Change Permissions
    Click the Owner tab
    Claim Ownership by clicking edit, then selecting administrator and checking the box that says replace permissions.


    There may be some programs running in the background that can interfere with Guild Wars 2, if that's the case try this:
    Type msconfig in the start menu
    Click the Startup Tab
    Click Disable all
    Click Okay

    When your computer restarts try starting Guild Wars 2.

    If this doesn't fix the issue, delete the files entirely. NEVER touch the registry, as you can corrupt your system. The only time you should be instructed to touch registry is when a licensed computer professional tells you to do so. Never download the client from any unoffical source or links from forums. Download the client from the email sent to you by ArenaNet.

    If this still does not resolve the issue, you may be infected with malware. Please take the time to download any virus checker and scan your computer for any infections. I suggest Microsoft Security Essentials, it is free of charge and created by Microsoft and extremely light weight

    If everything above fails to work, your registry may be corrupted because you deleted the keys. If that is the case, you need to do a system restore. Try the built in Microsoft System Restore.
    Last edited by Deyadissa; 2012-04-26 at 06:12 AM.
    The most important thing to realize is, no matter what you experience you are never alone; no matter what you are struggling through, there is always someone who is more unfortunate.

    It's Ok to Be Takei (Rank 35/ Fractal Level 22)

  6. #6
    For me it works in this way: right click at the GW2.exe (Launcher) and execute as an administrator.

  7. #7
    give rights to write to the whole guild wars 2 map mostly fixes the problem did it for me.. i already had it installed and all of a sudden it became a Read-only map very werid.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts