I found my old SW: RS 3D at home, which is a game from 1998, and I remember myself playing it 10 years ago on an older computer than my current.
I've been trying a lot lately to get the game running again, but I have some problems with it. I've browsed around on a lot of emu forums (but all really old threads).
I managed to get past the install problem (nothing happend after pressing install) and the opening problem (instant crash) by installing a fixed version of the game.
Now my problem is that my FPS freezes when it tries to load the menu. The intro cinematic runs all good.
I have tried to run in Compatility Mode, all of them, all with the same result. I'm using a fixed No-CD crack because the original doesn't work.
Any that have any solutions, maybe emus to get it running? I miss the game

2.4 Ghz Intel Core2 Duo
nVidia GeForce 320M
Windows 7 Ultimate 32bit

EDIT: I'm sorry if this is not the correct section for this, I was a bit in doubt if it should be here or the Computer section