1. #1

    Trouble Registering


    So I just bought this game, and tried to register. I fill in the code I got and press 'No' (it asks you if you already have a Guild Wars account). It then says this:


    There was an unspecified error. Please try again.'

    Can anybody help me?

    Edit: Just a second ago I got into the next screen (filled in my name, email, etc.) but then when I wanted to finish registering it gave me the same error. Then I tried again and I have the same problem I had in the beginning again.

  2. #2
    Their website is being shitty. GL registering, it took me two hours to get the email reset for my password, but I still can't finish the reset via their website.

  3. #3
    Scarab Lord
    Join Date
    Oct 2007
    Comox Valley, BC
    I am running into the same error. I've put a ticket in with their support team, hopefully they can rectify this for us.

  4. #4
    I finally go through. If you try often enough it'll work :P

  5. #5
    yeah their website server is timing out due to overload.

    Just keep mashing that register button, I got mine after about 10mins.
    having a Guildwars 1 account helps even if you don't own the game.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts