Thread: Shadowstep bug?

  1. #1

    Shadowstep bug?

    Is it just me or whenever I use shadowstep on a mob/boss in a heroic dungeon, it teleports me in front of it. In other words, I'm facing his ugly face. This is an issue for me since I'm practicing subtlety and i can't freaking backstab them if i keep on facing their front. I also tested this on a random NPC and voila, i'm not even behind him. This doesn't happen when I'm not in heroic. I haven't tried other specs. I also run into an issue where I start autoattack no reason when I'm near trash while being in stealth. Anyone of u guys encounter this or is it just me?

  2. #2
    I'm not sure about the shadowstep bug but if you are right-clicking a mob to target it, you will autoattack when you get in range.

  3. #3
    Nope I simply left click or TAB it to the target.

  4. #4
    I used Killing Spree on a mob in a dungeon, it ported me under the zone and killed me. The teleport mechanics have been buggy for as long as I can remember.
    I am the lucid dream
    Uulwi ifis halahs gag erh'ongg w'ssh

  5. #5
    .....Really? No one else is experiencing this glitch? It's so annoying! It either ShS me in front of the target, near the tank (then again I want to ShS to tank's target, which puts me in front of the target), and sometimes it's JUST works (if I get close enough to target, stop moving, then ShS). I searched on google and some say it happens when you're moving or some speed increase to your boots or something. Some threads were created in bnet's forums but no solution. I wonder if disabling addons will help. They're all updated and all. My latency is decent. Reduce Input Lag is enabled. I'm running outta ideas. Oh and no i don't use a macro for ShS.

  6. #6
    falling through the ground can happen if you port to a creature half way in the ground. you can get trapped in cages and similar environment doodads if you port to an enemy and it was behind him. (which is one reason why the killing spree glyph is helpful) Can sometimes happen if there was an elevated ground object behind it, in which case your feet spawn INSIDE the ground elevation and you fall through like mario.

    If you're lucky you fall and die. if you're not, you get d/ced and cant access that char till a GM does it for you.

    ---------- Post added 2012-10-11 at 07:18 AM ----------

    Quote Originally Posted by Zodiar View Post
    I'm not sure about the shadowstep bug but if you are right-clicking a mob to target it, you will autoattack when you get in range.
    left click is manual selection and tab selects the closest target (sometimes >>) and cycles but...

    right clicking a mob is the function to targetselectattack. its the manual initiation for auto-attack. Its why your char goes into a combat stance when you right click a mob from far away.
    Last edited by Tenjen; 2012-10-11 at 07:20 AM.

  7. #7
    This happens to me with players, but that's probably due to lag. KSp does not put me in the same place as ShS however, and I've had serious problems with KSp just not hitting a moving player, probably because of range.

  8. #8
    The Patient Matutin's Avatar
    Join Date
    Sep 2010
    Buenos Aires, Argentina
    well i ran to this problem on heroic spine quite some months ago...

    also, if you are using the glyph of Disguise, just be sure to not pickpocket one of those giant monkeys and use shadowstep, since i got teleported below the floor and either fall to my death or just had to tel out/in
    My Rogue

    Veni, vidi, vici.

    I like MoP now c:

  9. #9
    If it's any consolation, I am also having this issue with Shadowstep. Sometimes it doesn't even teleport me at all.

  10. #10
    Herald of the Titans Galbrei's Avatar
    Join Date
    Jul 2010
    I've had the occasional problem of Shadowstep teleporting me under the enemy, making him see me even while in stealth.

  11. #11
    Same Galbrei, I have had that problem too.

  12. #12
    I know on the quest where you throw your dragon a ball he can run through cliffs.. and if you shadowstep him then it doesn't end well

    (well.. someone had to try)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts