1. #1
    Bloodsail Admiral Ryzo's Avatar
    Join Date
    Aug 2010

    CD-Rom drivers not installing

    My optical drives don't work, both of them. They're pretty standard DVD drives, data and power cables are tested and working with other drives and are connected fine, but the troubleshooting wizard in win 7 won't install drivers for the devices. I can only try them 1 at a time due to my lack of cables, but each time I get a simmilar message pop up when trying to install drivers, basically telling me it failed.

    Going further through the wizard I come to this screen -

    Uploaded with ImageShack.us

    The drives worked fine maybe a fortnight ago, I haven't changed anything since then.

    I have no idea what to make of it, I was hoping you guys could give me a hand.


    Edit --- Problem resolved, if possible this post should probably be deleted
    Last edited by Ryzo; 2012-11-09 at 04:42 PM.
    If you spend your entire life getting senpai to notice you, you'll never notice anyone else.


  2. #2
    I am Murloc! Cyanotical's Avatar
    Join Date
    Feb 2011
    could you post how you resolved it for reference

    i7-6700K | Z170 Class. K | 16GB DDR4-3200 | GTX-980ti | Samsung 950 Pro RAID0 | SuperNOVA 1Kw P2 | Lian Li PC-07S
    ROG Swift PG348Q | Ducky DSX | Zowie ZA11 | Xonar Essence One | Tannoy Reveal 402

  3. #3
    The Lightbringer Hanto's Avatar
    Join Date
    Oct 2010
    Quote Originally Posted by Cyanotical View Post
    could you post how you resolved it for reference
    I agree. One the most annoying things ever when it comes to troubleshooting your own stuff is when you find someone with a problem exactly like yours, nobody can figure it out... then the OP fixes it on their own and just announces it, giving no clue as to how they fixed it. It's driven me up a wall a few times. :|

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts