1. #1

    Guild wars 2 won't download

    Hey everyone

    About 2 days ago I had to reinstall my windows because of some technical errors with my pc. I wanted to download Guild Wars 2 again but after launching the client I get the following message "Download failed! Please check your internet connection and try again."
    My internet connection is perfectly fine and my windows firewall isn't the problem either so I have no idea what's wrong.
    Anybody have an idea what might be causing this cause I really want to start leveling my engineer again

    Thanks in advance!

    Greetings!

  2. #2
    Try this:

    Go into your Users\My Docs\My Games\ and look for your GW2 folder (I think that is the path, but I'm at work and cannot verify). Once you find it, rename it to something else, like Guild Wars 2.5 or whatever. After you do that, launch the game. It should re-create the GW2 folder there and re-pull what it needs. This happened to me and it is failing because something in that folder became corrupted.

  3. #3
    Quote Originally Posted by Cyclone Jack View Post
    Try this:

    .
    The game isn't installed yet, it's the game client that doesn't want to install the game because I have no internet connection.
    So it says...

  4. #4
    Same problem as mind, i just bought the CD yesterday. I run it on my PC and it says "Download failed! Please check your internet connection and try again". there is no problem with my connection. please someone help, really want to play the game .

    thank you^^

  5. #5
    Scarab Lord Karizee's Avatar
    Join Date
    Oct 2011
    Location
    The Eternal Alchemy
    Posts
    4,433
    Someone else with what sounds like the same problem got this response - From the ArenaNet tracker on GW2Guru:

    http://www.guildwars2guru.com/arenan...wont-download/



    User: I’m getting the message: “Download failed! Please check your internet connection and try again”. I’ve tried disabling my firewall and running the setup as administrator, but I’m still getting the same message.



    Arenanet: Just a few things – first and foremost, make sure there’s no security software currently enabled as they’re the usual culprit.

    Next, Guild Wars 2 requires TCP ports 80, 443, 6112 and port 6600 be fully unrestricted and accessible, both inbound and outbound. If you are connecting to Guild Wars 2 while on a campus, military, or business network, please check with your network’s administrator to verify that these ports are fully opened and unrestricted. If you are on a home Local Area Network (LAN), you will want to make sure that your network’s hardware is properly configured.

    Msconfig never hurts as this allows you to rule out any conflicting apps right away.

    Aside from that, you can also try a Winsock reset.
    Valar morghulis

  6. #6
    i dont know how to do it karizee. im using wifi at my home. how to configure it?

  7. #7
    you may also try "Run as Admin" when starting the game up.

    If you have access to your wifi router, you can normally check the router for the login address and pw, then login and open the ports you need open or give Guild Wars access.

  8. #8
    how to do it? how to enable it?

  9. #9
    Keyboard Turner wakfufangirl189's Avatar
    Join Date
    Jun 2019
    Location
    the world of twelve. specifically bonta.
    Posts
    1
    i have the same problem but i have tried EVERYTHING!!! even what you guys said!!! please help (even my pet firefly joris is sad)

    - - - Updated - - -

    i know its 2019 but ppl still use this ofr awnseres..... right

  10. #10
    Had issues running the setup exe within the browser. Was getting the message that I need admin rights (while I was running the exe as admin). Went directly from my user files and managed to run the installation from there.
    20-6-2019 started playing the game, better later than never!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •