1. #1

    WoWhead not loading properly (All browsers)

    I load up the site, but every page has massive chunks missing, like the flash/java or script just isn't working.

    This extends to specific item pages too.

    I have tried a different browser.
    I have tried disabling AdBlock.

    But each time it's the same.

  2. #2
    Fluffy Kitten Majad's Avatar
    Join Date
    Mar 2011
    Everything is fine on my Chrome. It's probably your java that isn't updated or something, I wouldn't know, but try and update them?
    Perfect Illusion

  3. #3
    This always happens to me as well. I've used all the browsers and same thing. I'll try and update my Java but I have a brand new laptop and it shouldn't need an upgrade.

  4. #4
    I had this happen to me yesterday evening, it seems solved now.

  5. #5
    Dreadlord Eruionmel's Avatar
    Join Date
    May 2010
    Washington, USA
    It's an issue with their servers. They tend to get overloaded now because of the huge amount of people who use the site nonstop. When it's only loading partially it's because they are running out of bandwidth.

    | PM Signature Requests: Closed | My Work | Signature Tutorial |

  6. #6
    Having the same problem. Anyone has a fix for this?

    I've already tried changing the value of network.http.sendrefererheader from "2" to 1 and 0, no change. (apparently the Referer was a problem some people had.)
    You were good, kid, real good. But as long as I'm around, you'll always be second best, see?
    Oh, and no comment from Xe'ra about how the assault on the black temple was being led in part by the naaru. So was hatred corrupting A'dal's mind too, you pretentious windchime?
    - Volpethrope

  7. #7
    Having this same problem with newest firefox. Have tried deleting cache/cookies and nothing seems to help so far.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts