1. #1

    Exclamation Launcher error fix?

    Hello there fellow champions!

    I just tried to log into WoW but something very strange happened. The game was up to date, everything cool, I click the Play button. But then the Launcher restarts and shows that there is some content to be downloaded. After a few seconds this error shows up:

    "ERROR: The file "D:\Games\World of Warcraft\Updates\wow-0-16683-Win-final.MPQ" appears to be corrupt. You may need to download this file again."

    What in the world is this? I tried restarting the launcher and stuff. The first time I can click Play, it restarts and the same error shows up.

    I would really appreciate some help here, never seen this before.
    Last edited by 6ev4enko; 2013-03-11 at 10:11 PM.

  2. #2
    I've been having a similar problem. However, I get a error message saying "error message occurred, please contact customer support".

  3. #3
    just delete the file in question and restart the launcher

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts