1. #1

    transmog limitations with old item sets?


    I just bought:


    I try to transmog them on:


    and it just doesn't work. Any other items I can transmog without problems, yet this I can't.

    Anyone see any issue here? Or what's wrong? Don't have any addons turned on. I get the popup "transmog will make it untradable" yet it doesn't work.

    as in I click on apply and nothing ever happens >_<

  2. #2
    A few weeks ago I was having trouble getting a shoulder "transmog" to stick on my monk. The next day, it worked. Not sure what the issue was, was going to put in a ticket but it resolved itself the next day.

  3. #3
    Stood in the Fire S Blieft's Avatar
    Join Date
    Dec 2011
    Not sure if you've tried, but sometimes fully exiting the game client and then restarting it might work?
    I don't see any issue with the items, and as BirdLady68 said sometimes these things fix themselves.

    Hopefully you get it working, that lock set is pretty badass.
    And eight, eight, I forget what eight was for

  4. #4
    Went to Pandaland town and it worked there >_> Seriously, what's up with those NPC's lately.

  5. #5
    Quote Originally Posted by lanerios View Post
    Went to Pandaland town and it worked there >_> Seriously, what's up with those NPC's lately.
    IDK transmog bugs sometimes. I always have to double check when I log back in after doing a new piece because they lose it sometimes. Ive never been blocked from mogging something that should work though.

  6. #6
    Banned -Superman-'s Avatar
    Join Date
    Feb 2013
    Unsubbed til flight returns.
    Might want to submit it to the Bug Forums on the main site and see if they are experiencing the same issue or if they have acknowledged and fixed the issue yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts