Page 4 of 4 FirstFirst ...
  1. #61
    GODDAMNIT we are in the wrong thread. I'm deleting my tricks post and putting it over there.

  2. #62
    has anyone tried this on qiraji battleguards yet? I'd hope it would work on them, since they are so awesome
    Warlorcs of Draenorc made me quit. You can't have my stuff.

  3. #63
    Used "falling down" way, got it in a first try, far to easy.

    A Tip: Picture says to "bring some gold as you will be dying a lot" you dont need your gear, strip naked and retry until you get the wings, when you got them, equip your gear back. They will disappear, just use /reload and they will be back.

  4. #64
    Seems this may have been fixed with the 5.4 patch. I've had the wings for about a week, then I logged in after the patch and they were gone. Tried getting them back using the method in op's post (how I got them in the first place) and it seems the glyph now properly transforms you into a Mantid for 5 minutes.

    Oh well. It was fun while it lasted.
    Constructs in *my* raid?

    It's more likely than you think.

  5. #65
    I successfully got my wings back, but they disappeared after logging out again.

  6. #66
    But just to be clear, we still can't skip the cinema, combo points go away on the adds in several new fights just like in every tier (pretty damned sure this happened on watchers), and I couldn't open the dungeon journal last night without reloading UI.

  7. #67
    Haste will fix it. Soon™
    A witty saying proves nothing.
    not quite Batman
    "A stick is a love letter that hasn't been made into paper yet."
    plus ça change, plus c'est la même chose

  8. #68
    I was able to get wings on every single try this afternoon (7/7). This evening, I'm 0/25. Appears hotfixed.
    I played a rogue in a place. I play in another place now. You've probably seen me around.

  9. #69

    This bug should have been left forever. It was perfect.

  10. #70
    Just tried this using the "fall to death and pick pocket" -method and got the wings on first try. So it seems that it is still working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts