1. #1

    iOS authenticator issue: impossible to fix.


    Couldn't find another thread, so here we go.

    Basically, my iOS auth stopped working before I even applied the iOS update. I never apply updates if I can avoid it since my phone is rather old and I find every update makes it more and more sluggish (3GS).

    I then found their official statement on the fact authenticators on IOS are having issues. I have the restoration code, so NP, I apply that as Blizz said I should. Nothing, didn't work.

    I actually update the iOS software, thinking if I actually patch to what is supposed to cause the problem, that the solution to said problem may work (thsi logic, it is strong in me). Nothing. I re-restore the authenticator with the code. Again, nothing.

    I mean what? How is this even possible? Anyone has any solution, I will call them later today but I mean what actually happened that my auth broke over an update I never even updated and is now impossible to fix?

    Also, what time can I actually call them, since the official site no longer lists opening hours that I can find, only that phone support is now "unavailable" (EU).
    Last edited by Cirque; 2013-09-18 at 05:52 AM.

  2. #2
    Greetings Cirque.

    I need a little more clarity when you say that the authenticator is not working. Is the application failing to open/crashing? Or is the application generating an incorrect code?

    As you have tried to restore the authenticator, I would assume that the application is working but generating an incorrect code.

    First, try to Sync the authenticator if you haven't already. To Sync the authenticator, open the authenticator app, select the "View Code" option and tap the circular arrows icon on the bottom left. A message will be displayed if the sync was successful (the phone will need to access the internet via WiFi or 3G to be able to sync the authenticator).

    Also check the Date and Time set on your phone. I have experienced a situation where the application generates an incorrect code, if I change the date or the time.

    Let the phone automatically set the time. (Settings > General > Date and Time > Set Automatically > On). The phone will need access to the internet for it to query the servers and get accurate data. After the date and time have been set, sync the authenticator and it should start generating the correct codes.

    Do let us know if either of these solutions help you out :)
    Last edited by H2SO4; 2013-09-18 at 07:45 AM.

  3. #3
    Brewmaster Thundertom's Avatar
    Join Date
    Oct 2009
    The Netherlands
    Quote Originally Posted by H2SO4 View Post
    Also check the Date and Time set on your phone. I have experienced a situation where the application generates an incorrect code, if I change the date or the time.
    This is very important. I had a malfunctioning authenticator as well due to this.

    Also, since it's maintenance right now, perhaps it cannot sync correctly? I'm not sure how that works, but you might want to try it after the maintenance is over.

    I had some issues with the app when I changed phones, and it took me 30 mins to get the thing removed and add a new one due to Blizzards quick help, so if all else fails it should be quite easy to fix anyhow.

    Good luck.

  4. #4
    Thank you guys for the replies, I will try this right away, as I just called Blizzard and they said they removed the auth but they in fact did not (ye I don't know :S) so I still cannot log in.

    The error is "incorrect value" when I enter the code on the login, the app itself works fine. If you're unaware, there are issues with the iOS authenticator as stated in the Breaking News section of Blizzard. It has broken magically, one day it worked, the next it didn't - nothing was changed. I have not changed time and date either, but I will try all your suggestions nonetheless.

    - - - Updated - - -




  5. #5
    Fluffy Kitten Darsithis's Avatar
    Join Date
    Jan 2011
    Glad it's been fixed for you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts