Beta Key Giveaway Week 3: Winners have been selected!

  1. #1

    Laggy wow, addons or computer?

    Hey!
    So, i got a pretty good computer it should be able to handle wow, 1080 i5 6600k 3.5ghz etc,
    In raids with everything set to low except particle density which is fair, i have like 30 fps.
    playing priest so i have an insanity bar and a few mer WA's + ElvUI.
    Looking at how much MB it takes wa is about 12-14 mb & elvui the same, yet i lag alot in raids.

    i really dont wanna change away from elvui or the weakauras cause im very used to it, anyone got a suggestion what i can do?
    Thanks

  2. #2
    AddOns really don't do much in terms of memory usage, but they can cause FPS drops (especially nameplates and buffs/de-buff tracking), easiest way to check is simply turn all your AddOns off and do LFR or something to see if it still happens. If so, you know it's likely something on your PC's end.

    Could also check your temps/GPU/CPU usage and add it here, could be a mix of multiple issues.

  3. #3
    Try disabling your addons, its possible if your weakauras are out of date they could slow down performance but it shouldn't be that much. Are you running any CPU heavy programs in the background?

  4. #4
    Did you buy your extended wow package from your service provider?

  5. #5
    I would try to find out if the cpu and gpu are functioning correctly outside gaming. Sounds alot like faulty hardware. I have 1060 and much older cpu and I have alot better fps.

  6. #6
    Disable addons, see if it helps, if not make sure shadows and that outline feature isn't on ultra, don't forget to get latest drivers for your gpu. If win10 turn off auto updates, seems it only needs to start updates when you need those resources.
    Disarm now correctly removes the targets’ arms.

  7. #7
    Have you ensured Wow uses your nvidia GPU and not the Intel one?

  8. #8
    Quote Originally Posted by kevinftw92 View Post
    Hey!
    So, i got a pretty good computer it should be able to handle wow, 1080 i5 6600k 3.5ghz etc,
    In raids with everything set to low except particle density which is fair, i have like 30 fps.
    playing priest so i have an insanity bar and a few mer WA's + ElvUI.
    Looking at how much MB it takes wa is about 12-14 mb & elvui the same, yet i lag alot in raids.

    i really dont wanna change away from elvui or the weakauras cause im very used to it, anyone got a suggestion what i can do?
    Thanks
    Make sure your wow combat lot is not HUGE! This happened to me once and caused the same issues you are talking about.

  9. #9
    its neither. wow is just very un-optimized and the new raid especially. it's not your pc or your addons.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •