1. #1

    Question Private Messages blocked

    Hello, I just noticed today that I can't use private messages feature, not for sending or receiving, there is no option on my settings to turn this on or off, I may have missed many giveaways, and I don't want to miss bfa beta key giveaway again !

    so anyone can help with this ? is there a hidden option somewhere ?

    Sorry I just found the option to turn it on.
    Last edited by dlhak; 2018-05-17 at 04:49 PM.

  2. #2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •