1. #1

    Exclamation LUA error every time I log in (pic included)

    Hello everyone, I'm hoping someone here has a clue as to why I'm receiving an LUA error every time I log in to WoW. All of my addons are up to date so I'm not sure what's causing this error. Please see the screenshot attached.

    Thanks

    https://imgur.com/a/Mkz0b5P

  2. #2
    So there is a lot of trouble shooting that needs to be done. But it seems to be based on your chat frame, so any addon that affects chat needs to be reset/turned off/tweaked. Even if you don't have a specific addon dedicated to chat, some extension is interfering with the new chat.

    The first thing you need to do is turn off all your addons, then turn each one on and log in/reload to see which one it is.

    Then if that doesn't work you need to turn on your addons and turn off one individually and log in or reload your ui until you pinpoint it.
    Last edited by Gaexion Ramza Beoulve; 2018-08-10 at 01:57 PM.

  3. #3
    When you get a Lua error, you’re supposed to copy the text and paste that. There’s more lines to that error we can’t see in the screenshot. There’s also two errors there, the second one may be related and may help people figure out the problem.


    addons
    weakauras
    Lua Wall of Shame
    WoW soundnames (4.5 MB)
    Originally Posted by Zarhym (Blue Tracker)
    this thread is a waste of internet

  4. #4
    Quote Originally Posted by Kanegasi View Post
    When you get a Lua error, you’re supposed to copy the text and paste that. There’s more lines to that error we can’t see in the screenshot. There’s also two errors there, the second one may be related and may help people figure out the problem.
    Here's the full error:

    Message: Interface\FrameXML\ChatFrame.lua:4307: bad argument #2 to 'SetFormattedText' (string expected, got nil)
    Time: Fri Aug 10 16:07:04 2018
    Count: 1
    Stack: Interface\FrameXML\ChatFrame.lua:4307: bad argument #2 to 'SetFormattedText' (string expected, got nil)
    [C]: in function `SetFormattedText'
    Interface\FrameXML\ChatFrame.lua:4307: in function `ChatEdit_UpdateHeader'
    Interface\FrameXML\ChatFrame.lua:2960: in function `ChatFrame_ConfigEventHandler'
    Interface\FrameXML\ChatFrame.lua:2892: in function `ChatFrame_OnEvent'
    [string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>

    Locals: (*temporary) = ChatFrame3EditBoxHeader {
    0 = <userdata>
    }
    (*temporary) = "Tell %s: "
    (*temporary) = nil
    (*temporary) = "string expected, got nil"

    Message: Interface\FrameXML\ChatFrame.lua:4310: bad argument #2 to 'SetFormattedText' (string expected, got nil)
    Time: Fri Aug 10 16:07:04 2018
    Count: 1
    Stack: Interface\FrameXML\ChatFrame.lua:4310: bad argument #2 to 'SetFormattedText' (string expected, got nil)
    [C]: in function `SetFormattedText'
    Interface\FrameXML\ChatFrame.lua:4310: in function `ChatEdit_UpdateHeader'
    Interface\FrameXML\ChatFrame.lua:2960: in function `ChatFrame_ConfigEventHandler'
    Interface\FrameXML\ChatFrame.lua:2892: in function `ChatFrame_OnEvent'
    [string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>

    Locals: (*temporary) = ChatFrame4EditBoxHeader {
    0 = <userdata>
    }
    (*temporary) = "Tell %s: "
    (*temporary) = nil
    (*temporary) = "string expected, got nil"

  5. #5
    Whether you have a chat addon or not, either the addon or Blizzard's UI seems to keep trying to set the editbox for ChatFrames 3 and 4 to the last character or bnet person you whispered, but since this is happening upon login, there is no saved character or person in the editbox's frame attributes. My assumption is that you don't have any chat addons, you use Blizzard's whisper tabs, and each tab has its own editbox.

    This may actually be related to all the BN_WHISPER FIXME comments I've seen sprinkled in Blizzard's chat code.

    One of my theories to fix this without resetting your chat settings is changing Chat Style to "Classic Style" in Interface > Game > Social. This forces one chat box, which belongs to ChatFrame1. Your whispers will still go to their assigned frames, but the editbox will only remember the last thing you did overall, not per frame. For example, if you just typed something in Trade, then clicked a whisper tab, your editbox will still be set to Trade. You'll have to /w characterorperson or rightclick their name.


    addons
    weakauras
    Lua Wall of Shame
    WoW soundnames (4.5 MB)
    Originally Posted by Zarhym (Blue Tracker)
    this thread is a waste of internet

  6. #6
    Quote Originally Posted by Kanegasi View Post
    Whether you have a chat addon or not, either the addon or Blizzard's UI seems to keep trying to set the editbox for ChatFrames 3 and 4 to the last character or bnet person you whispered, but since this is happening upon login, there is no saved character or person in the editbox's frame attributes. My assumption is that you don't have any chat addons, you use Blizzard's whisper tabs, and each tab has its own editbox.

    This may actually be related to all the BN_WHISPER FIXME comments I've seen sprinkled in Blizzard's chat code.

    One of my theories to fix this without resetting your chat settings is changing Chat Style to "Classic Style" in Interface > Game > Social. This forces one chat box, which belongs to ChatFrame1. Your whispers will still go to their assigned frames, but the editbox will only remember the last thing you did overall, not per frame. For example, if you just typed something in Trade, then clicked a whisper tab, your editbox will still be set to Trade. You'll have to /w characterorperson or rightclick their name.
    Still doesn't work. What I had setup before prepatch dropped was a tab for whispers, a tab for bnet tells, and a tab for everything else and that seems to be the issue. I recreate them and upon logging in they are auto-deleted and I get the LUA error. I get the LUA error even when I don't recreate the separate chat windows. Never had this issue before prepatch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •