1. #1

    Slow texture,character,map loading

    So I don't have any problems with loading screen,its pretty fast.But once I get in,it takes like 15+ seconds to load character around,some objects,map will almost always bug out and so on...whats the cause of this ?

  2. #2
    The most likely cause to this is that you haven't fully downloaded the latest patch yet.

  3. #3
    I did,everything is updated including drivers

  4. #4
    I used to have serious problems with this in Legion. The only thing that helped was moving the game over to an M2 drive with 2.5 GBps transfer speed... And I think there's a texture streaming setting you can turn off, though that'll probably make loading screens longer instead.

  5. #5
    SSDs are your friend, friend.

  6. #6
    The Unstoppable Force breadisfunny's Avatar
    Join Date
    Dec 2012
    Location
    flying the exodar...into the sun.
    Posts
    24,523
    Quote Originally Posted by Twdft View Post
    SSDs are your friend, friend.
    ssd's won't help with rendering the world. wow is cpu bound not hard drive bound. the only thing they would help with is his loading times. you also seem to be assuming he doesn't already have one since he didn't state if he had one or not.
    Last edited by breadisfunny; 2020-01-21 at 09:36 PM.
    r.i.p. alleria. 1997-2017. blizzard ruined alleria forever. blizz assassinated alleria's character and appearance.
    i will never forgive you for this blizzard.

  7. #7
    Quote Originally Posted by breadisfunny View Post
    ssd's won't help with rendering the world. wow is cpu bound not hard drive bound. the only thing they would help with is his loading times. you also seem to be assuming he doesn't already have one since he didn't state if he had one or not.
    Im using HDD,i thought SSD is ONLY FOR LOADING SCREENS,but apparently is has connection with loading in game stuff.I just found this video https://www.youtube.com/watch?v=L9rpQo69wicwhere his HDD has same problems as mine,check around 4:13 min.While with SSD had no problems.

  8. #8
    Mechagnome Gonder's Avatar
    Join Date
    May 2010
    Location
    The Shadowlands
    Posts
    686
    Well, I'm currently using a computer with an SSD and one with a HDD and the HDD suffers from the exact same problem and has been since Legion. The loading screen finishes and a lot of the time, not even my own character has finished loading in, so I get stuck on the same spot for several seconds. I usually jump on my flying mount and use my minimap to navigate until stuff finally loads in. At first, I thought it was my computer slowly dying in terms of performance but I don't know, something in the game definitely must have changed at some point for this to have started happening.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •