Page 1 of 8
1
2
3
... LastLast
  1. #1

    Server problems every day since patch, is this just the way it is now?

    Seems like they don't care that there is server lag and/or crashing literally every day since patch. There hasn't been a single day since patch where I played and there wasn't some form of problem. It hasn't been this bad ever, even in Classic where it was routine for there to be lag and massive downtime every week it still wasn't every day without a break.


    Getting kinda tired of paying money to lag I'll be honest.
    Your persistence of vision does not come without great sacrifice. Let go of the tangible mass of your mind, it is only an illusion. There is no escape.. For the soul burns on everlasting encapsulated within infinite time. A thousand year journey at the blink of an eye... Humanity is dust..

  2. #2
    Quote Originally Posted by Vakna View Post
    Seems like they don't care that there is server lag and/or crashing literally every day since patch. There hasn't been a single day since patch where I played and there wasn't some form of problem. It hasn't been this bad ever, even in Classic where it was routine for there to be lag and massive downtime every week it still wasn't every day without a break.


    Getting kinda tired of paying money to lag I'll be honest.
    Since i have had no lag or server crash since pretty much day after the patch.

    Us or EU and what are you runing Wow on and what type of connection?

  3. #3
    Haven't lagged or crashed a single time outside of the times when people are chain killing the world boss right after reset which has been causing lag in Nazjatar back in 8.2 too. Sounds like a you problem.

  4. #4
    Over 9000! Mirishka's Avatar
    Join Date
    Nov 2010
    Location
    Get off my lawn!
    Posts
    9,499
    Haven't had any lag/connection issues since 8.3 outside of an issue that was related to my ISP/service, not WoW.

  5. #5
    Quote Originally Posted by Vakna View Post
    Seems like they don't care that there is server lag and/or crashing literally every day since patch. There hasn't been a single day since patch where I played and there wasn't some form of problem. It hasn't been this bad ever, even in Classic where it was routine for there to be lag and massive downtime every week it still wasn't every day without a break.


    Getting kinda tired of paying money to lag I'll be honest.
    It's all poor performance server side. I get the same lag in panda land, everyday, same story. It's been better as of late, but it's still there.

  6. #6
    Quote Originally Posted by Raven View Post
    Since i have had no lag or server crash since pretty much day after the patch.

    Us or EU and what are you runing Wow on and what type of connection?
    It's EU and it's not me, everyone else in general chat complaining about it every time it happens also. My internet connection is better than Blizzard's.

    On Monday people were even getting kicked out of M+ keys and Visions cus the servers were taking a shit, Blizzard posted about it on their twitter account and seemingly did nothing to remedy the problem, because we are still getting just as much lag.

    - - - Updated - - -

    Quote Originally Posted by Adoxe View Post
    Sounds like a you problem.
    Definitely not.
    Your persistence of vision does not come without great sacrifice. Let go of the tangible mass of your mind, it is only an illusion. There is no escape.. For the soul burns on everlasting encapsulated within infinite time. A thousand year journey at the blink of an eye... Humanity is dust..

  7. #7
    Legendary! Nnyco's Avatar
    Join Date
    Oct 2011
    Location
    Haomarush
    Posts
    6,308
    Sounds to me like its a problem on your side. Havent seen any issues since 8.3.
    Originally Posted by Blizzard Entertainment
    Crabs have been removed from the game... because if I see another one I’m just going to totally lose it. *sobbing* I’m sorry, I just can’t right now... I just... OK just give me a minute, I’ll be OK..

  8. #8
    Agreed OP, had issues as well, playing on high pop especially ruined AH. They say they are looking into it, but damn...AH lags so bad on maany servers, I left feedback here, hope others will report the lag issues on AH too

    https://eu.forums.blizzard.com/en/wo...a-reply/124904

    - - - Updated - - -

    Quote Originally Posted by Nnyco View Post
    Sounds to me like its a problem on your side.
    Stop....just stop. If you go to a shop and buy a pair of new jeans and there is an issue with the clothing you wouldn't accept that either - We pay for ACCES to the game, thats literally what we pay for...If we have issued with said thing then...
    Youtube channel: https://www.youtube.com/c/djuntas ARPG - RTS - MMO
    NZXT H440 - Asus Z97 A Mobo - Corsair RM 850 - Intel I5 4590 CPU - Evo TX3 Cooler Master - Asus 970 Strix - 250GB SSD 850 Evo - Seagate Barracuda 1TB HDD - Windows 10

  9. #9
    Stood in the Fire
    Join Date
    Dec 2019
    Location
    Sweden
    Posts
    481
    Since the patch?

    More like since bfa launch. I play on EU silvermoon and there has been problems since launch of bfa with insane delays on interacting with objects, using abilities etc.

  10. #10
    Legendary! Nnyco's Avatar
    Join Date
    Oct 2011
    Location
    Haomarush
    Posts
    6,308
    Quote Originally Posted by Djuntas View Post
    Stop....just stop. If you go to a shop and buy a pair of new jeans and there is an issue with the clothing you wouldn't accept that either - We pay for ACCES to the game, thats literally what we pay for...If we have issued with said thing then...
    Stop what? I got zero problems. My pair of jeans are fine, maybe its your fat ass that doesnt fit into the jeans.
    Last edited by Nnyco; 2020-02-12 at 01:41 PM.
    Originally Posted by Blizzard Entertainment
    Crabs have been removed from the game... because if I see another one I’m just going to totally lose it. *sobbing* I’m sorry, I just can’t right now... I just... OK just give me a minute, I’ll be OK..

  11. #11
    The very least they should be doing is giving us a month of free game time for this 3 weeks of bullshit we are having to endure. Doesn't look like they are going to fix it anytime soon either.
    Your persistence of vision does not come without great sacrifice. Let go of the tangible mass of your mind, it is only an illusion. There is no escape.. For the soul burns on everlasting encapsulated within infinite time. A thousand year journey at the blink of an eye... Humanity is dust..

  12. #12
    The only time I lag is during the Battle for Nazj. event when there's two large groups of both factions going at it.

  13. #13
    Quote Originally Posted by Vakna View Post
    My internet connection is better than Blizzard's.
    proof or stfu.


    On Topic: This latest patch has had several issues, at least on EU side. The world boss in Vale of Eternal Blossoms is laggy as shit (then again, the Nazjatar world bosses were laggy too, just not as much imo).
    Adding to that, on Monday for example, had massive dc and b.net going down when we were raiding which was annoying AF (boss at 8%, mass dc....gg wp)
    From Beta: "WoW is now a turn-based game, GG"

  14. #14
    Quote Originally Posted by Djuntas View Post
    Agreed OP, had issues as well, playing on high pop especially ruined AH. They say they are looking into it, but damn...AH lags so bad on maany servers, I left feedback here, hope others will report the lag issues on AH too

    https://eu.forums.blizzard.com/en/wo...a-reply/124904

    - - - Updated - - -



    Stop....just stop. If you go to a shop and buy a pair of new jeans and there is an issue with the clothing you wouldn't accept that either - We pay for ACCES to the game, thats literally what we pay for...If we have issued with said thing then...
    but if you buy a pair of jeans and your crazy gf sets them on fire you dont go to store to get refund... so if its problem on his side not on blizz side its reallye HIS problem... that said it could be problem on blizz said, dont know, had zero issues since day 3 of patch

  15. #15
    I'm having lag too, in EU we even had a server restart.

    Last time I noticed I was in my desert server, joined a Ha-li kill group and after leaving the group it was a pain to play, 2 days ago or so.

  16. #16
    To infinity and beyond det's Avatar
    Join Date
    Aug 2008
    Location
    The forums
    Posts
    34,249
    I think I had two or three moments of latency issues, nothing which makes the game unplayable, just really seeing it on the latency display of my castbar addon.

    Can't remember a server crash or DC.

    Oh wait...I think I had "Instance couldn't be found" when I tried to portal from Nazjatar to Zuldazar.

    English EU RP PvE server / cross realm

  17. #17
    Quote Originally Posted by khabal View Post
    proof or stfu.
    I don't actually know what kind of connection Blizzard has, it was hyperbole to iterate on the fact that my connection is perfect and it's definitely not a "me" problem. Further iterated on by the fact that everyone else in general chat gets it at the same time.


    The people that are saying they haven't had lag or that it's a me problem were probably just not online at the time of the lags. The fact that Blizzard even acknowledged the problem 2 days ago (though did nothing about it) further decreases those people's credibility.
    Your persistence of vision does not come without great sacrifice. Let go of the tangible mass of your mind, it is only an illusion. There is no escape.. For the soul burns on everlasting encapsulated within infinite time. A thousand year journey at the blink of an eye... Humanity is dust..

  18. #18
    There's a default delay of 130+ ms on all outdoor zones.

    You will never see your true latency figures until you go into a raid where it is only about 10+ ms higher than your actual measured ping against the target server.

    That is due to the amount of processing done at the backend on the machine. You can't get around that. My guess, is it's likely the anticheat software. Which unfortunately has to be there if they don't want to increase CS costs. Sux for us.

    But outside of that, there have been much bigger spikes in lag during the obvious rush-hour activities, killing a boss, new assault popping etc. The usual.

    They're doing their best, as far as their constraints allow them to.

  19. #19
    Had no issues aside from the first few days and the general lag that's always there when a few raids try to murder the world boss.

  20. #20
    I haven't had any lag problems either since patch. I am on US.

    But as everyone else said, I only get lag when I join a world boss raid group. But that's to be expected every time. I got that kind of lag before patch too and basically since they introduced world bosses lol.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •