1. #1

    Question How to start leveling in BFA?


    Had a DK at like 98 before squish i wanted to level after squish, i had started the legion stuff and leveled up to 45 after squish and now i want to do the last levels in BFA, but i cannot for the life of me figure out how to start quest there.

    Chromie does not offer BFA as a campaign, and if i chose "Return to current timeline" there isn't any starter quests to go to BFA content. Portal in SW portal room for Boralus is inactive, so can't go that way either.

    Interwebs said it was possible to level from 10-50 in BFA, but not how.

    Does anyone know how to start the BFA campaign on a level 45 alliance character?

  2. #2
    BFA is the default timeline as far as I know, you don't have to talk to Chromie at all. I had a similar character and I believe there was a quest in Stormwind or in my log already and I just followed it.

  3. #3
    It seems to be bugged, i am unable to get into BFA on my 45 hunter, 41 priest and 41 mage ....
    Yes am in default timeline (at least chromie says so..), but interestingly there are cata quest available on those two 41lvl toons....

    So i told to myslef - whatever, i will use timewaling, but nope, those questlines given by chromie seem to end after first quest...

    So i opened a ticket .. wait time is just 5 days

    seems juuuust great, 3 days unable to login, 4th day unable to level-up and counting...

  4. #4
    Yeah, i've tried everything i can think off, flew around all of SW looked at all availible quests, took boat to boralus, but there isn't anything active there either. Just gonna finish up somewhere else and hope it's fixed when i want to level next time.

  5. #5
    Quote Originally Posted by nesty View Post
    It seems to be bugged, i am unable to get into BFA on my 45 hunter, 41 priest and 41 mage ....
    Same here. Characters with Legion involvement before squish are stuck in phase limbo (lvl 40 - 45). For some of them, the BFA intro quest popped up but the questline stopped after just a few quests. For others, the intro quest did not pop up at all. Workaround: take the ship to Boralus, do sidequests on the BFA continents.
    Teamwork is essential - it gives the enemy someone else to shoot at!

  6. #6
    i have a lvl-10 player level 10 (alliance), unable to start questing in BFA, no quests to start the process.

    - dungeon finder is defaulted to BFA, with 1 dungeon specific choice Freehold and random also gives Freehold?
    - mission board has quest to start WOD, MOP, and WOTLK zones, guards near it, have no quests or dialogue
    - king anduin had a quest, i took it, the follow up guest is "The Mission" this sends you to the skyfire....MOP related, did not continue
    - chromie offers all zones except BFA
    - go to SW docks, and phasing is off, not showing all the stuff that my alliance saw for BFA. i have nine alliance level 50s.

    from several blue posts and SL sale pitch, BFA was default for new accounts, veteran players could go to chromie to choose other zones to level other than BFA, obviously defaulted but not working.

    update, went to the legion and WOD timeline did some activities got to 20, went back to SW and chromie, changed timeline to present time, it had no effect.

    my player is a mage, when a was in dalaran i trained all the portals, i ported to boralus still no quests, but able to use island expedition board and que for those

    blizzard at times uses deep and heavy legalize when speaking, so i take it, spamming islands and getting XP = BFA leveling, if you get tired of it....head to chromie
    Last edited by pinkz; 2020-10-19 at 09:29 PM.

  7. #7
    This has been bugged since Wednesday, I would wager they're working on fixing it.

    Oddly, only Alliance had been plagued with this bug. Numerous posts all over forums have already been made, and Blizzard are aware of it.

  8. #8
    Fixed as of a few hours ago. Tested allied race new non allied race to level 10 via regular leveling and exiles reach and a few existing toons. Was able to see and get tides of war on all of them.
    Last edited by Zergin8r; 2020-10-20 at 04:33 AM. Reason: Phone autocorrect sucks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts