1. #1

    Nvidia Drivers - An Unknow Error Has Occured

    Hello,
    I just bought an NVIDIA GeForce GTX 1660 SUPER OC Edition 6GB GDDR6 PCI Express 3.0 to update my gaming PC. However, once I tried to install the drivers I kept getting the message "An Unknown Error Has Occurred." I previously had an HD Radeon GPU and I have used DDU to delete all drivers, before installing the drivers for the new GPU. My monitor is currently plugged into the cards DVI slot and works. Device manager doesn't show the card, only the native one.
    As far as the driver install goes. I begin the install. It asks for the desired location, which I left on default. Then it begins loading the green bar, and once it reached 100% it display the error message. I can only click ok on it and it will exit the install. I have also tried older versions of the driver and same result. I will post the build below. Thank you all in advance

    Motherboard: ASRock Z77 Pro3
    CPU: Intel i5-3570k
    Previous GPU: HIS IceQ Radeon HD 7870
    Memory: G.SKILL Ripjaws Series 8GB (2 x 4GB)
    OS: Windows 7 Professional 64-bit

  2. #2
    Sounds like a fake GPU. Are you sure you purchased an authentic 1660 SUPER?
    i7-6700K @ 4.6GHz cooled by Thermalright Silver Arrow IB-E Extreme | ASRock Fatal1ty Z170 Gaming K6+ | 16GB Corsair Vengeance LPX DDR4-3000/CL15 @ 3200/CL14 | MSI GTX 1070 Gaming X | Corsair RM650x | Cooler Master HAF X | Logitech G400s | DREVO Excalibur 84 | Kingston HyperX Cloud II / Samson SR850 | BenQ XL2411T + LG 24MK430H-B

  3. #3
    Try uninstalling any nvidia drivers/software from program list and download the Nvidia GeForce experience software. After reboot and open GeForce experience and create an account and once in, it gives you the right driver to download and install.

  4. #4
    Please wait Temp name's Avatar
    Join Date
    Mar 2012
    Location
    Under construction
    Posts
    13,018
    Windows sometimes tries to install drivers while you're doing it yourself, which can cause conflict (Because windows sucks). Try DDU again, and then let your system idle for 20-30 minutes, then install drivers again.

  5. #5
    Moderator chazus's Avatar
    Join Date
    Nov 2011
    Location
    Las Vegas
    Posts
    16,869
    Quote Originally Posted by pimphand69 View Post
    Device manager doesn't show the card, only the native one.
    This right here says to me that there's a hardware issue. No matter what drivers or software or anything is being used, SOMETHING should show up here, even just "Generic Video Device" or something. But nothing? I'd first double check to make sure the card has power, and reseat it, and make sure its in the correct PCIE slot.
    Gaming: Dual Intel Pentium III Coppermine @ 1400mhz + Blue Orb | Asus CUV266-D | GeForce 2 Ti + ZF700-Cu | 1024mb Crucial PC-133 | Whistler Build 2267
    Media: Dual Intel Drake Xeon @ 600mhz | Intel Marlinspike MS440GX | Matrox G440 | 1024mb Crucial PC-133 @ 166mhz | Windows 2000 Pro

    IT'S ALWAYS BEEN WANKERSHIM | Did you mean: Fhqwhgads
    "Three days on a tree. Hardly enough time for a prelude. When it came to visiting agony, the Romans were hobbyists." -Mab

  6. #6
    Sometimes products can come from the factory bad. It happens. Happened to me a few months back with a Sapphire Pulse Radeon RX 580. Bashed my head against the wall repeatedly trying every trick under the sun to get the damn thing to install correctly and work correctly. Finally just RMAd it after a couple of days. I received my replacement, and it installed easily the first time, and I have had wonderful results with it ever since. You may have just gotten a bad card. Good luck!

  7. #7
    Thank you all, unfortunately the driver installation never completes. There is a PIC device listed under "Other Devices" on Device Manager, but it has no drivers. I might just return it and try a different make or model.

  8. #8
    You may need to reinstall os. There’s a button in settings or control panel to reinstall on windows 10. Put your stuff on cdr or usb. Or dropbox. Then if it don’t do right buy new gpu?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •