1. #1

    The Mail Notice Function Still Does Not Work Properly

    The little icon next to your character, that tells you, that you have mail, that was something that went live with the start of the expansion a year ago, and they had to take it out several times. Last patch they already tried to fix it. This patch, they tried again, and it still doesn't work. Now it tells you, that you have mail, when you don't have any mail anymore. Even the symbol on your minimap tells you, that you have mail, when you've completely emptied your mailbox. After a year of trying and failing, I thought they might finally get this little feature fixed.

  2. #2
    The Undying Gehco's Avatar
    Join Date
    Apr 2010
    Location
    FEEL THE WRATH OF MY SPANNER!!
    Posts
    34,579
    Huh.. Works fine for me..
    FOMO: "Fear Of Missing Out", also commonly known as people with a mental issue of managing time and activities, many expecting others to fit into their schedule so they don't miss out on things to come. If FOMO becomes a problem for you, do seek help, it can be a very unhealthy lifestyle..

  3. #3
    It doesn't. When you log out, even though your mail box is empty, it still shows the mail icon.

  4. #4
    The Patient Pannekaker's Avatar
    Join Date
    Jan 2011
    Location
    Drammen, Norway
    Posts
    292
    Works fine for me as well

  5. #5
    i get the same behaviour

  6. #6
    Master of the Void The Dark One's Avatar
    Join Date
    Jun 2008
    Location
    The Void
    Posts
    2,081
    Worked fine for me also.

    Perhaps it's a mod interaction?
    Fundamental civil rights are only "political" if you're trying to take them away from people.

  7. #7
    I noticed when I had an auction that sold, the mail icon would pop up even though I had time left before I got paid. Perhaps that's what others are experiencing?
    The icon was there both logged in and at the character select when I was waiting on a payment for a sold auction.

  8. #8
    I am Murloc!
    Join Date
    Sep 2014
    Location
    Australia
    Posts
    5,575
    literally just logged into a character with a mail icon, got my mail, logged out and mail icon is gone. so it's something on your end causing this, maybe an addon?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •