1. #1

    400 Bad Request - Firefox

    For the past few days I've been getting this error on MMO-C. Sometimes the frontpage loads but thats it, clicking through some recent posts will just give me the 400 Error with a "nginx/0.7.59" line below.
    Right now I'm using Opera and everything works. I've tried clearing cookies&cache rebooting and restarting FF nothing seems to really work. Sometimes my saved open pages will load and I might flip through a page but soon after I'll get the 400 again.
    Any ideas?

  2. #2
    Sounds like perhaps you have something in your registry that doesn't belong or some adware.

    Might want to do some maintenance.

  3. #3
    Miss Doctor Lady Bear Sunshine's Avatar
    Join Date
    Mar 2009
    Location
    San Francisco
    Posts
    15,651
    Usually the 400 error means you should clear your cookies... but I'm actually seeing the same thing where sometimes I get them in short sequence. Looking into it, though

  4. #4
    Alright, did a fullclear of cookies&cache again and deleted about every other temp file I got on my PC, looks like it's working again.

  5. #5
    Miss Doctor Lady Bear Sunshine's Avatar
    Join Date
    Mar 2009
    Location
    San Francisco
    Posts
    15,651
    Good news, everybody! Dinnerbone has figured out what the cause is, and we're working on a fix.

  6. #6
    Fluffy Kitten bahumut5's Avatar
    Join Date
    Aug 2008
    Location
    The Netherlands
    Posts
    4,904
    Quote Originally Posted by Sunshine View Post
    Good news, everybody! Dinnerbone has figured out what the cause is, and we're working on a fix.
    Does it include MOAR COOKIES???
    You can never have enough of them

    Anyway, on errors:
    400-499 = Your own problem (clear cache, history etc)
    500-599 = Dinnerbone's problem (OMFG CALL 911 ARGHHHHH WE'RE GONNA DIE!!!11!)

    Just keep that jingle in your head and you are fine (note: Other errors rarely/never occur).
    Dawwwwwww

  7. #7
    Epic! Milanor's Avatar
    Join Date
    Jul 2009
    Location
    That place...with the stuff.
    Posts
    1,564
    I was wondering what the problem was and why we weren't seeing a post on 400 Bad Request-Champion yet.


    Thanks!

    Just Your Average Lurking Huntard LOLPRIEST forum lurker now.

  8. #8
    The problem is you're using Firefox...
    Get Google Chrome and be pro

  9. #9
    Quote Originally Posted by bahumut5 View Post
    Does it include MOAR COOKIES???
    You can never have enough of them

    Anyway, on errors:
    400-499 = Your own problem (clear cache, history etc)
    500-599 = Dinnerbone's problem (OMFG CALL 911 ARGHHHHH WE'RE GONNA DIE!!!11!)

    Just keep that jingle in your head and you are fine (note: Other errors rarely/never occur).
    OMG not the 502 ...
    Dinnerboneeeeeee fix it plox

  10. #10
    Fluffy Kitten bahumut5's Avatar
    Join Date
    Aug 2008
    Location
    The Netherlands
    Posts
    4,904
    Quote Originally Posted by Shazzia View Post
    The problem is you're using Firefox...
    Get Google Chrome and be pro
    Ow you.
    Everybody knows that Chrome is just a story to scare children for the Internet.
    Dawwwwwww

  11. #11
    Fluffy Kitten Dinnerbone's Avatar
    Join Date
    Jul 2008
    Location
    Somewhere in England. I'm not too sure.
    Posts
    2,143
    Little clarification on this bug; It may sound odd, but it's actually caused by lurking the forums too much. Seriously. The more (unique) threads you open, the quicker you are to getting a 400, regardless of browser.

    We should have a fix soon, but in the mean time just clear your cookies if it ever happens.
    Join us on the official MMO-Champion IRC channel!
    #mmo-champion of irc.quakenet.org or click here if you have no idea what I'm talking about.

  12. #12
    Fluffy Kitten bahumut5's Avatar
    Join Date
    Aug 2008
    Location
    The Netherlands
    Posts
    4,904
    Quote Originally Posted by Dinnerbone View Post
    Little clarification on this bug; It may sound odd, but it's actually caused by lurking the forums too much. Seriously. The more (unique) threads you open, the quicker you are to getting a 400, regardless of browser.
    So your advice towards me is to stop browsing the forums?
    My god... I can only imagine the Horror... Trolls..... Everywhere.... Nowhere to run.... We are all gonna die O.o
    Dawwwwwww

  13. #13
    I had been getting the same error too suddenly. Removing the cookie for here fixed it! Had me worried...
    To purr, or not to purr...

  14. #14
    Quote Originally Posted by bahumut5 View Post
    So your advice towards me is to stop browsing the forums?
    My god... I can only imagine the Horror... Trolls..... Everywhere.... Nowhere to run.... We are all gonna die O.o
    I'll take care of them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •