So I seem to be unable to download a patch. At least I think that's the problem. I've tried running the background downloader and every time I run it it downloads the same 4.68 GB of 'WoW-"3.3.x-to-4.0.0-patch-NA-Stages-1-3"...' And when I try to log into the game I go the the page that has you select United States, Oceanic, or Latin America, and then pvp and whatnot, so I select what I want and get a list of realms but everything is red, I try to log into my server, get stuck at connected for awhile and then get 'you have been disconnected from the server' I don't see any patch in my wow folder that says anything about 4.0.anything, but the blizzard updater tells me there's no patch to apply.

Does anyone know if this means I've been able to download the patch and something else is wrong, or have I not been able to download it and maybe downloading from a mirror site would help? I run on a mac so finding a mirror site that has the mac version is a little tough. And unfortunately blizzard tech support still hasn't responded to my plea for help