1. #1

    Problem downloading large files

    Lately my internet hasnt been allowing me to download large files and i dont know much about modems/routers whatnot so i decided to ask the computer smart people here on mmo-champion.

    My problem is that whenever i try to download larger files my internet just shuts off completely for about a minute. I have no problems just surfing or downloading small files so I dont really know what's wrong with it. I never lose connection to my network so i dont think it has anything to do with my router which leaves me thinking that something must be wrong with my modem which is pretty old (toshiba pcx2600). I also do not have to restart my modem/router to get the internet back on again, it just fixes itself after a minute or so.

    So my question is, do you guys thing that buying a new modem will help fix the problem? I'm going to call my service provider soon and ask them about it also, but any help here would be greatly appreciated.

  2. #2
    High Overlord Markro's Avatar
    Join Date
    Sep 2009
    This is a really weird issue and I'm not entirely sure what the problem could be. You might have to do the old, process of elimination. Do you have a spare modem or one you can borrow to run a few tests? Also, out of curiosity, how large are the files, what format (are they the same format?), also, what stage of the download does the problem occur (near the end, beginning, random etc..).
    Markro - Arthas US PvP

  3. #3
    Can you define the large file size as MB or GB and how you are trying to download those files? p2p spftware? or just like "Save as..."? after that try this;

    Try downloading files from which servers are in your country and try to download from outside from your country.

    If you didnt say "My router" I could think its a connection in office or smthng that you cant manage. So Last chance contact to ISP.

  4. #4
    Have you tried downloading a large file directly connected to the modem to eliminate the router as the cause completely?

    Have you tried another computer? (If not, have you tried updating network drivers, turning off firewalls, trying a different networking card?)

    Also, run a speed test at http://speedtest.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts