Page 1 of 2
1
2
LastLast
  1. #1

    problems with getting WoW cataclysm mmo gaming mouse to work

    Hi there.

    I've looked around on the internet and such for around one hour now, without finding any answers to my problem.

    My problem is, that I just bought my WoW cataclysm mmo gaming mouse from steelseries, and I can't figure how to get it to work with its extra buttons etc. I can use it as a standard mouse with two buttons and scroll, but I can't use the extra buttons and change the DPI.

    I have installed the software which is needed to get the mouse to work, according to steelseries. However it doesn't seem to work and I would really like to hear if any of you knows how to solve this problem

    Thanks

  2. #2
    TOTALLY NOT
    Banned
    tetrisGOAT's Avatar
    Join Date
    Jun 2008
    Location
    Sweden
    Posts
    13,931
    Always install drivers online, throw away your disc ;P
    See i' you can download them 'rom their site

  3. #3
    I have downloaded it from steelseries own site, but still not working :/ Didn't get a disc

  4. #4
    Check the box under interface>mouse>Enable WoW Mouse inside the game. This should activate your mouse. It often gets disabled for no reason and you just have to check the box. Hope that helps.

  5. #5
    It is enabled, but still no luck

  6. #6
    Stood in the Fire
    Join Date
    May 2010
    Location
    England, that's as close as I'm letting you guys know ;)
    Posts
    439
    You sure you've assigned the buttons to do anything? Sometimes they come as just pure blankness and don't do anything until you've assigned them and told your computer they exist
    Irage Gaming.
    Battlefield 3 and CS:GO gaming community!

  7. #7
    Yes I have, it is just like the software and mouse aren't working together

  8. #8
    Quote Originally Posted by Mortore View Post
    Yes I have, it is just like the software and mouse aren't working together
    If you are running windows vista/win 7, Run the gamingmouse software in Adminmode. I had to do this for my Logitech MX Revolution (got a G700 now, i wanna get home to try it!!!) for WoW to recognize the buttons ingame.

    To run in adminmode, just kill the software, rightclick on the exe file and choose "run as Admin"

    Maybe, just maybe you need to run WoW as admin also. Some need to do it, some doesnt.

  9. #9
    Nope, running windows XP

  10. #10
    if you go into keybindings and hit a mouse key, does it bind to that abillity or does nothing happen?

  11. #11
    yeah it does bind a key, but I can't change the key. Quite annoying since some of the keybinds which is premade for the buttons is for example T or G, which I already use on my keyboard

  12. #12
    hum thats wierd, my mobile internet dongle is FUBARing atm so i have a hard time locking down the problem, but ill see what i can get hold of between the disconnects. Hopefully someone else with a more stable connection or even a mouse like yours know whats up.

  13. #13
    uninstall the softwer u downloaded, atleast that worked for me.

  14. #14
    Thanks a lot I appreciate that

    ---------- Post added 2010-12-27 at 12:16 AM ----------

    Quote Originally Posted by Dreamman View Post
    uninstall the softwer u downloaded, atleast that worked for me.
    Nah didn't work

  15. #15
    Are you sure it actually works with Windows XP to begin with?


    I was contemplating on getting the mouse myself, but after the Razer Naga didn't work and had to be returned, I'm still a little unsure. The Reviews I've read online so far all seem very favorable besides pointing out that the mouse is fucking huge (which is good for me).

  16. #16
    As much as I hate saying this in this thread:
    glad I got me a Razer Deathadder and a Razer Lycosa. No BS, yet very comfortable

    There are several things that could cause the though, it's best to contact Steelseries Tech Robot uhhh I meant Support.
    Quote Originally Posted by Nudi View Post
    I got 99 problems, but a totem ain't one.

  17. #17
    Quote Originally Posted by Crowe View Post
    Are you sure it actually works with Windows XP to begin with?


    I was contemplating on getting the mouse myself, but after the Razer Naga didn't work and had to be returned, I'm still a little unsure. The Reviews I've read online so far all seem very favorable besides pointing out that the mouse is fucking huge (which is good for me).
    Yeh well it should work XP, and I think the mouse is great in itself.. I would just wish I could get it to work

    ---------- Post added 2010-12-27 at 01:31 AM ----------

    Quote Originally Posted by Tandurin View Post
    As much as I hate saying this in this thread:
    glad I got me a Razer Deathadder and a Razer Lycosa. No BS, yet very comfortable

    There are several things that could cause the though, it's best to contact Steelseries Tech Robot uhhh I meant Support.
    hehe I would also wish i had bought that one instead But yeh.. will maybe contact em tomorrow
    Last edited by Mortore; 2010-12-27 at 01:24 AM.

  18. #18
    Quote Originally Posted by Mortore View Post
    yeah it does bind a key, but I can't change the key. Quite annoying since some of the keybinds which is premade for the buttons is for example T or G, which I already use on my keyboard
    Have you enabled "Enable in-game mode" inside the software for the mouse? Should be just below the character portrait.
    That changed the mouse buttons into Mouse Button 1-14 inside my interface menu, while before the keys were mapped to my keyboard instead.

    Also, anyone with the mouse managed to get their character's profile loaded into the software? It seems to be unable to find my character's armory.

  19. #19
    A driver update was released 27 DEC 10 that should fix the WoW character profile issue, which was caused when Blizzard changed the web address of the armory.

    Not sure why your key bindings won't work but... the mouse ships with default key bindings that you should check first. If those work and yours don't you have isolated part of the issue. Remember, that you have to click the "Apply" button to save your changes, but the software should warn you that you haven't done that if you try to exit the program before doing so.

    There are some issues with this mouse (I'm on my second one). First, it is highly (as in HIGHLY) susceptible to static discharge. Last week, I walked to my computer across carpet, reached for this mouse, and static electricity discharged from my finger to the mouse, killing it. Thank God the mouse ate the charge and it didn't reach my MOBO.

    Second, both mice I've had don't want to be recognized at boot up. I have to unplug and then replug them in the USB port to get them to be recognized. My guess is that this has something to do with the gold plating on the Cataclysm mouse's USB connector. The first mouse is a paperweight now due to the static discharge issue, and I'm still fiddling with the second one regarding the USB recognition issue.

  20. #20
    I have had the same problem with my new mouse - I can map the buttons fine inside WoW, but the steelseries software outside the game does not work correctly. I have downloaded & installed the latest (Version: 1.08. Released: 2010-12-27) & it has rectified the character retreival issue woth WoW Armory, however the buttons to remap remain inactive so I cannot remap any buttons (in the help file they show as red, whereas mine show grey). I can modify other setting tho - eg the pulsing light & tracking speed.
    I have an open ticket with Steelseries at the moment - 7 days ago & am still waiting for a reply to reolve this issue.

    ---------- Post added 2011-01-07 at 12:47 PM ----------

    Steelseries replied to my ticket - disabling the “Enable in-game mode” option did the trick – I didn’t realise that the “Enable in-game mode” is mutually exclusive of the Steelseries software. I was presuming that any changes made in the software would reflect in the in-game button mapping and vice-versa (ie that any mapping done from within WoW would display in the software interface). I also tested the software mapping in notepad as they suggested & all worked OK.
    I will probably continue using the in-game mapping anyway as this seems more intuitive than the software – but nice to know that the software isn’t broken so I can use that method if desired.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •