1. #1

    Unhappy My water elemental doesn't attack

    Hey guys. My issue is that my water elemental refuses to attack any target. I can use the pet-nova, which is great but i really don't see a reason for it not to attack. I can press attack, aggressive and such but it still doesn't do anything. Just stands there beeing one of those bullied water elementals.
    Have any of you mages experienced anything like this?

    Thanks for you time

    - Flodhäst, Ahn'qiraj.

  2. #2
    Tryed using the command /petattack ?

  3. #3
    Yep, doesn't work :<

  4. #4
    Never happened to me.....i can't suggest you anything else than opening an in-game ticket...

  5. #5
    did you turn off autocast for water bolt by any chance?

  6. #6
    Your current one has down syndrome. Get a new one.

  7. #7
    haha i lol'd, +1

    ---------- Post added 2011-01-07 at 03:30 PM ----------

    LOOOOOOL it was right, thanks lol

  8. #8
    This is also happening to me, I can macro in pet attack and or waterbolt to my frostbolt, but it only attacks once for everytime I press the button/key then stops.

    Very odd

    haha I also had auto waterbolt turned off
    Last edited by jonamur; 2011-01-13 at 03:11 PM.

  9. #9
    My Water Elemental does everything but attack. It happened on the same day I tried out three different unit frames, but even with all add on's disabled I get the same result. I put in a ticket which took about 1.5 days for a GM to respond to, and he indicated that this is a known issue. Although I do not see any reference to it on any blizz forum. As a result I'm going fire for the first time since SSC.

  10. #10
    What I'd want to know is, does it actually look like its casting or is stood there as if it was on passive?

    It could be your macro is cancelling the Waterbolt cast, try removing /petattack from it for starters.

  11. #11

    Water Elemental is gimpy

    Yep, mine too..it's been driving me INSANE, especially when in BG's. I don't even use Macros; I want him aggressive during BG's. He just sits there and watches me die. Trying to manage him and fight is cumbersome. I can get the occasional one-shot of a frost bolt like a previous poster, but that's about it. It sucks, plain and simple. I hate my pet. I hate him. I want to see him evaporate painfully.

  12. #12
    Why would you want petattack macroed to your frostbolt? Sounds really stupid to me.. I dont want my elemental to assist me 100% of the time

  13. #13
    Quote Originally Posted by robob View Post
    Why would you want petattack macroed to your frostbolt? Sounds really stupid to me.. I dont want my elemental to assist me 100% of the time
    So that it doesn't initiate a server-side check to see if the WE is done casting before he winds up another waterbolt, thereby making him cast more often, which in turn increases your DPS

  14. #14
    It does not look like he is about to start casting waterbolt. The button acts like it is auto attacking, as in it sort of highlights itself. I can even hear the sound the from his first attempt to cast. If I click waterbolt he will attack, but only once.
    Last edited by Tettro; 2011-01-28 at 09:41 PM.

  15. #15
    i came out in the arena the other day to find all of my buttons greyed out, no ccs on the elemental and i wasnt mounted. it was just following me around while i got pummeled due to the lack of an important freeze

  16. #16
    Replace your frostbolt ability on your action bars with this macro

    #showtooltip Frostbolt
    /cast Frostbolt

    Call the macro Frostbolt aswel so you get the Frostbolt icon, and yeah. Thats what I use anyway, its nice.

  17. #17
    You shouldn't macro it because every time you tell your pet to /petattack, it's "attack" is to cast Water Bolt, which has a cast time. If you keep hitting it like most people do with buttons, it will just keep retrying to cast Water Bolt every time you press it.

  18. #18
    maybe so but ive had no issues, works nice for questing.. level 67

    ---------- Post added 2011-01-29 at 12:56 AM ----------

    because usually you cast 1 frostbolt before the elemental even starts to cast his bolt, so i was always clicking the pets attack button first.. then i asked in guild how to do macro it works good

    ---------- Post added 2011-01-29 at 12:57 AM ----------

    i recommend that macro anyway, but i dont know why your elemental doesnt work lol. but when it does work, use that macro :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts