1. #1

    Attacking / Wanding Error with my Priest

    Hi there,
    I don't know if it's a Priest bug in general or only in my case, but since the Patch I get a "Can't do that while pacified" error everytime I try to attack with my staff or my wand. When hovering the cursor over a target, the sword-like cursor doesn't appear too.

    What's wrong? Unequipping weapons and relogging didn't help. Maybe it's an AddOn failure?

  2. #2
    Or maybe Priests aren't allowed to wand anymore? :O
    Error still persists, would be nice to get any response regarding that problem.

  3. #3
    I can't say that I have had this problem... however I haven't tried to melee anything or wand anything since I was working on getting my unarmed skill up to 400 and 4 weapon skills up to 400 ><

    I'll try to remember to do this tonight and see.

  4. #4
    Just the other night I was wanding on Magmaw with no problems - I tend to wand during the head down phase to 'help' the DPS since I am regenning mana.

  5. #5
    The Lightbringer Siri's Avatar
    Join Date
    Dec 2008
    I have had issues with melee attacking in the past but I never had that issue extend to wanding.

  6. #6
    Ok I found the solution... right in the Battle.net Forum -_-
    I simply had to die again, seems like it was an error with the Spirit of Redemption or something.
    Now everything works again!

  7. #7
    solution go shadow! j/k, glad you got it worked out

  8. #8
    I am getting this error as discipline too, so most likely unrelated to SoR.

  9. #9
    Fluffy Kitten Ultima's Avatar
    Join Date
    Mar 2009
    I've had this in the past. I just re-equip my weapons, manually.
    I heal in the Arena
    Retired Moderator - Priest and PvP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts