Page 1 of 2
  1. #1

    Wowhead not working propely?

    Hello, For the past 2-3 days Wowhead hasn't been working for me. I can enter the site but when I enter there are no Menus, bars or anything and if I search on an item or anything no text popups or anything clickable, Anyone else have this problem or anyone knows how to fix it?
    <moderator removing broken image>
    Brushing before eating breakfast seems about as silly as wiping before you poop.

  2. #2
    Works just fine for me; have you tried clearing your browser's cache?

  3. #3
    Quote Originally Posted by Maledictum View Post
    Works just fine for me; have you tried clearing your browser's cache?
    If this doesn't do it try disabling any browser extensions/addons you might have as they can cause issues with some pages as well. Also, if you are using Firefox with the NoScript addon make sure Wowhead is allowed.

  4. #4
    As Maledictum said. But what browser are you using? Can be that browser have blocked wowhead

  5. #5
    Warchief Millhi's Avatar
    Join Date
    Jun 2010
    somewhere in this world
    works fine for me,

    maledictum and mawtex, deadweight said some things you can try, if that doesn't work i'll add more options to see if that works.

  6. #6
    the only problem for me its that the 3d model viewer isn't working but the rest is fine

  7. #7
    Using Mozilla Firefox and tried clearing the cache and disabled the extensions. But it still doesn't work.
    <moderator removing broken image>
    Brushing before eating breakfast seems about as silly as wiping before you poop.

  8. #8
    Stood in the Fire Riff's Avatar
    Join Date
    Mar 2011
    Sussex, UK
    Try an alternative browser to eliminate that avenue, then post a screenshot of what you are seeing when you view the faulty page in firefox.

  9. #9
    assuming nosript - temporarily allow each one until it works. then revoke temp permissions and permanently allow that one.

  10. #10
    You have to allow "" in noscript.

  11. #11
    Bloodsail Admiral BananaInsane's Avatar
    Join Date
    Mar 2010
    My location is irrelevant to your interests
    Doesn't work for me either the last few days, but I'll try what people have suggested in this thread :P

  12. #12
    I tried disabling Adblock, clearing my cache, tried another browser. Still not working. Im running Chrome at the moment

    "Remember there is always something cleaverer than yourself"

  13. #13
    same problem here, dont know how to fix
    using firefox

  14. #14
    Same here. A few days ago on all items it started saying the item isn't available anymore, the search stopped working properly and now nothing works.
    All I see is the Wowhead logo, the search box and some logo for a story about the next patch and Brewfest on Wowhead News, which actually works fine.
    Scuzzlebutt @ EU-Ravencrest

  15. #15
    Elemental Lord Rixis's Avatar
    Join Date
    Feb 2010
    can anyone even post pictures of what we're seeing? many of us are running it in firefox no problems (also, what version of firefox? have you tried different versions?)

  16. #16
    Well, I can't post any links but I described what I'm seeing in the post above. I'm using Firefox version 6.0.2 without NoScript.
    Scuzzlebutt @ EU-Ravencrest

  17. #17
    I'm also having the same problems with WoWhead - running Firefox 6.2 (upgraded to 7 today, still no luck). So was a guildmate. I have NoScript, but everything enabled for WoWhead (I even tried turning NoScript off entirely) and it still doesn't work. My guildmate was running Firefox with no addons at all and couldn't access. Yet for some reason it can't be Firefox alone - my boyfriend has Firefox 6.2 and it works fine on his PC.

    Anyone know what's up? I can't even ask or file a bug report on the site.

  18. #18
    The Lightbringer dragothica's Avatar
    Join Date
    Aug 2007
    I had the same problem on Google Chrome with its Adblock in use. It just started to block menus and hyperlinks even when the addon was toggled off. I cleared the cache a couple of times and booted the browser and then the site started to work normally. I also put the option on that the browser deletes all saved information after browsing ends.

    Also, I took a look into Google Chrome's Javascript Console and it was full of errors. This thing that isn't working might just be a Javascript Bug.
    Last edited by dragothica; 2011-09-29 at 10:12 AM.

  19. #19
    Herald of the Titans Theodon's Avatar
    Join Date
    Feb 2010
    Check to see if a script is running in NoScript. If it's not running and you aren't blocking it with NoScript then something else must be blocking it. If it is running then I have no idea what the problem is, but that script is responsible for basically all the data on wowhead now.

  20. #20


    Not working for me either, just a blank page with writing, about what i'am looking at. Would add a pic but it doesn't seem to be working..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts