Thread: Launcher Login

  1. #1

    Launcher Login

    Seeing that the Swtor website and forums are completely douched right now I'll bring my problem here.

    I run the launcher and put in my login name and password. It asks a security question. I answer it and the screen does this -

    I'd like to get the DL going. Anyone else have this issue or have an idea how to fix it?

  2. #2
    go to swtor main site , go in your account and set the security questions. for me worked. anyway right now server are a bit busy and will not go on with patching

  3. #3
    they updated their security policies. i'm not sure when, but go to the main site and check you meet the new password requirements and have your security questions set.

  4. #4
    it's extremely case sensitive, it wouldn't take mine at first.

  5. #5
    I'm also having major issues. It seems either their site is down from too much traffic, or they are doing maintenance.

  6. #6
    Bloodsail Admiral spaace's Avatar
    Join Date
    Jan 2009
    Ontario, Canada
    Bit of both.. They have a "queue time" on their website, at the moment.. 1.5m+ people getting ready for beta.

  7. #7
    I'm having the same problem as you OP but it actually says it won't allow me to login from my region, which is a bit weird as I'm in the UK.

  8. #8
    You're asking about the graphical issues? Like it's overlaying the security question box over the login info and basically glitching?

    First guess would be delete the launcher and retry, if that's your issue. Of course since the site is down that's easier said than done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts