1. #1

    WoWhead not working?

    Hi, since yesterday wowhead isnt working for me normally in wowhead homepage theres no text except for the icons i deleted cookies, cache, disabled my addons and used other browsers but nothing its still the same, anyone know how to fix it?
    Last edited by Sefetriex; 2012-09-04 at 02:32 AM.

  2. #2
    I have same problem, tried to google for like 30 min, found nothing.. ;/

    i;m using chrome

  3. #3
    Dreadlord internetheroxD's Avatar
    Join Date
    Sep 2009
    The Batcave, Sweden
    Works fine for me, using chrome aswell.
    Does it work now for you guys?

  4. #4
    Bloodsail Admiral Haftepaff's Avatar
    Join Date
    May 2011
    Using Firefox here and it's working just fine. Have you tried to connect to the website with a proxy?

  5. #5
    wowhead not working for me using Firefox/Chrome..... I have to use IE (IE works)

    EDIT : updating Java helped, wowhead is working again.
    Last edited by Kopuliak; 2012-09-04 at 03:56 PM.

  6. #6
    no it's not working for me, not even via proxy, I don't have other browsers except IE and it's not working there too, I've tried to reinstall java, even tried older/newer versions, still not working

  7. #7
    Tried clearing your cache? happens to fix all kind of problems.

    PS: Wowhead works for me on all browsers.

  8. #8
    yup, clearing cache works, thanks!

  9. #9
    Seems no one has an awnser in all the threads I see, if you figure out how you can fix can you put step by step instructions of what you did? /simpleton

  10. #10
    Moderator Nerph-'s Avatar
    Join Date
    Sep 2008
    Belgium, EU
    Hi Quexal, maybe this thread will be of more help to you:


    That thread was created yesterday and will probably be more active and get more replies if you post your problem there.
    Sports & Fitness Moderator

  11. #11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts