1. #1

    Vanish not putting me in Stealth?

    This has happened to me on more than just a couple of occasions: I Vanish (Vanish itself is supposed to put me in the 'Stealth' stance, no?) but I don't actually enter Stealth mode (as in my bars don't change and I can't use Stealth specific abilities such as Cheap Shot or Garrote) and have to wait for the Vanish buff to end to actually enter Stealth mode. This usually leads to me unable to follow Blinds with Saps or quickly Vanish -> Cheap Shot someone. Is there a way around this, or has anyone even had this happen to them?

    Note that this bug doesn't occur every Vanish, but far too often and costs me wins often.

  2. #2
    That's the infamous bar lag that players have been trying to solve for a while. I'd suggest reading these few posts:

    http://www.skill-capped.com/forums/s...arlag&p=116188

    Long story short, you can make some macros to help with shadow dance, but not stealth.

  3. #3
    Quote Originally Posted by Shimitsu View Post
    That's the infamous bar lag that players have been trying to solve for a while. I'd suggest reading these few posts:

    http://www.skill-capped.com/forums/s...arlag&p=116188

    Long story short, you can make some macros to help with shadow dance, but not stealth.
    Code:
    #showtooltip
    /cast [stance:0] Shiv
    /cast [stance:1,3,mod:shift,target=focus][] Sap

    That's my Shiv/Sap macro. Vanishing and then mashing 3 (the key the macro's bound to) will cause it to Shiv instead of Sap, meaning it wasn't just bar lag.

    Edit: And no, it's not just server lag (or lag on my end either), because I need to wait 3 seconds for the Vanish buff to dissipate.
    Last edited by Vereesa; 2012-07-18 at 11:29 AM.

  4. #4
    well i just did a small test with my rogue. and out of the 3 times i needed to wait for stealth. probebly a bug. noting you can do about it

  5. #5
    Quote Originally Posted by Vereesà View Post
    Code:
    #showtooltip
    /cast [stance:0] Shiv
    /cast [stance:1,3,mod:shift,target=focus][] Sap

    That's my Shiv/Sap macro. Vanishing and then mashing 3 (the key the macro's bound to) will cause it to Shiv instead of Sap, meaning it wasn't just bar lag.

    Edit: And no, it's not just server lag (or lag on my end either), because I need to wait 3 seconds for the Vanish buff to dissipate.
    Oh I see what you're saying. This is a problem on beta (at least last I knew) where the first couple seconds of the vanish buff don't count as normal stealth. This results in the new talent Subterfuge not working at all after vanishing. To be honest, I haven't noticed the same problem on live, but it's probably related.

  6. #6
    Legendary! Holo's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    6,287
    Quote Originally Posted by Vereesà View Post
    Code:
    #showtooltip
    /cast [stance:0] Shiv
    /cast [stance:1,3,mod:shift,target=focus][] Sap
    Should be

    Code:
    #showtooltip
    /cast [stance:0] Shiv
    /cast [stance:1/3,mod:shift,target=focus][] Sap
    You're welcome

    i5-3570k @ 4.4GHz|8GB DDR3 1600MHz|EVGA GTX 670 FTW x2 SLI|Samsung 830 128GB SSD

  7. #7
    Quote Originally Posted by Holo View Post
    Should be

    Code:
    #showtooltip
    /cast [stance:0] Shiv
    /cast [stance:1/3,mod:shift,target=focus][] Sap
    You're welcome
    I'll give that a try.

  8. #8
    Legendary! Holo's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    6,287
    If it still persists you could also try this:

    Code:
    #showtooltip
    /cast [stance:0] Shiv
    /cast [stance:1/2/3,mod:shift,target=focus][] Sap
    Though i highly doubt that is needed.

    i5-3570k @ 4.4GHz|8GB DDR3 1600MHz|EVGA GTX 670 FTW x2 SLI|Samsung 830 128GB SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •