Thread: Lichborne Bug

  1. #1

    Lichborne Bug

    Has anyone else noticed that Lichborne is not working properly anymore since MoP?

    When I use it and heal myself sometimes within 6 seconds or less remaining and I want to continue healing it begins to say Invalid Target


    I have tested this excessively so far I only know horn of winter triggers this and also some enemy mage/shadow priest spells on me.

    I have enough runic power.

    I am not silenced or affected by any other CC.

    Lichborne is still active.

    It still doesn't work tho, this bug already cost me a couple arena fights so I would be happy to know what other things cause this bug and if anyone has a solution for it so far.

    My lichborne macro is:

    #Showtooltip Lichborne
    /cast Lichborne
    /cast [target=player] Death Coil


    Thanks in Advance

  2. #2
    Do you have the glyph that creates a shield from death coil? I was under the impression that can, and usually does, bug out self heals through lichborne.
    Rogue from 2004-Summer 2005
    Pally from Summer 2005-WOTLK Release
    DK tank, All WOTLK including HLK.
    DK DPS, Heroic Firelands... Didn't raid Tier 11, or normal mode Firelands
    Formerly of Medivh-US

  3. #3
    I used to run around with it a lot, but never used the glyph for the shield. Never had issues with it myself

  4. #4
    No I am not using the shield glyph.

    Also my Lichborne Macro is binded on F2 and Death Coil on Mouse Binding (shift modifier=heal pet) If that is important in any way. I have however not changed the macro or keybindings since WotlK and it worked fine until now.

  5. #5
    Quote Originally Posted by Ravendale View Post
    Do you have the glyph that creates a shield from death coil? I was under the impression that can, and usually does, bug out self heals through lichborne.
    It sounds like it could be this, the glyph for shamans ghost wolf that allow them walk on water while in ghost wolf form always interrupts any cast I try to do while in ghost wolf form.

    Edit: Oh nm, try changing the macro to have target self in there somewhere? Not really sure what it could be.

  6. #6
    Field Marshal ghostomc's Avatar
    Join Date
    Dec 2010
    Location
    North Carolina
    Posts
    57
    ive experience similar things with useing lichborne myself

    useing lich at full runic power get 2 off then i use horn of winter spam anything that will give me runic power to top me off then go back to lich to heal and it wont work

    ive actually been feared will lich was up as well. very glitchy.

  7. #7
    Had the same, apperantly use !Lichborne, works.

  8. #8
    Stood in the Fire Wolfbear's Avatar
    Join Date
    Jan 2012
    Location
    Scotland
    Posts
    425
    It has happened to me a couple of times, not recently though.
    If you had the chance tae change yer fate... would yae?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •