1. #1

    Unable to log into my account on the official website

    Hello there. Does someone else have the same problem?

    Since yesterday evening I am unable to log into my account on the official website. My account is not frozen or anything because I can still log into the game. I also created (albeit by mistake, I mixed my e-mail address since I haven't played in a long time) a starter account, was able to log in but am also unable to log into that one (of course also on their website) since yesterday evening (~12 hours ago?).

    Does someone else have the same problem? If so it might be on their end and not my fault. I also deleted the cache and cookies and everything but nothing helps. And as said, I am able to log into the game and play normally, I could reset my password but I am unable to log into the website.

  2. #2
    Dreadlord Nykolas's Avatar
    Join Date
    Nov 2012
    Location
    Birmingham UK
    Posts
    914
    Quote Originally Posted by Marston View Post
    Hello there. Does someone else have the same problem?

    Since yesterday evening I am unable to log into my account on the official website. My account is not frozen or anything because I can still log into the game. I also created (albeit by mistake, I mixed my e-mail address since I haven't played in a long time) a starter account, was able to log in but am also unable to log into that one (of course also on their website) since yesterday evening (~12 hours ago?).

    Does someone else have the same problem? If so it might be on their end and not my fault. I also deleted the cache and cookies and everything but nothing helps. And as said, I am able to log into the game and play normally, I could reset my password but I am unable to log into the website.
    Delete cookies, history and saved passwords in your browser, works for me.

  3. #3
    As said, I already deleted those and it didn't help.

  4. #4
    The Patient paxx0r's Avatar
    Join Date
    Nov 2010
    Location
    Westeros
    Posts
    321
    I can't log in so i think its something on their end ><

  5. #5
    Alright, it works now. So it was probably a problem on their site.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •